DMZ to LAN: Windows file explorer rules.



  • Good Morning!

    I've just moved a machine from my LAN to my DMZ, and I want to be able to access a file share on a single machine inside the LAN.

    I've set up four firewall rules:

    Protocol: TCP
    Source: 192.168.12.202
    Destination: 192.168.10.101
    Port: 445

    Protocol: TCP/UDP
    Source: 192.168.12.202
    Destination: 192.168.10.101
    Port: 137

    Protocol: TCP/UDP
    Source: 192.168.12.202
    Destination: 192.168.10.101
    Port: 138

    Protocol: TCP/UDP
    Source: 192.168.12.202
    Destination: 192.168.10.101
    Port: 139

    Is this correct as I still do not seem to be able to access the shares. The shares are open (no password) shares, and I have also tried to disable the windows firewall on both machines for testing.

    Hopefully, someone can help me find out what I've done wrong.

    I've attached a copy of all my rules below.

    Thank you.
    ![DMZ Rules.PNG](/public/imported_attachments/1/DMZ Rules.PNG)
    ![DMZ Rules.PNG_thumb](/public/imported_attachments/1/DMZ Rules.PNG_thumb)


  • LAYER 8 Global Moderator

    Don't see any active states on your rules.. And only hits on the 139 rule.. You sure you have your IPs correct in your aliases..

    If your running smb over tcp you would only need 445 rule.. I would suggest you setup a rule to allow any from your ip to your ip.. Validate it works, can ping, etc.  Then via your states you see for your file transfer be it the 139 or 445 that your client machine is using limit your rule to that port..



  • @johnpoz:

    Don't see any active states on your rules.. And only hits on the 139 rule.. You sure you have your IPs correct in your aliases..

    Thanks John, I took the snip after I re-activated the rules, this is how it looks now:

    ![DMZ Rules.PNG](/public/imported_attachments/1/DMZ Rules.PNG)
    ![DMZ Rules.PNG_thumb](/public/imported_attachments/1/DMZ Rules.PNG_thumb)



  • @karldonteljames:

    …and I have also tried to disable the windows firewall on both machines for testing....

    I've just restarted the media-centre and switched the firewall off, and it allowed connection from other machine. File and print sharing is already enabled on that machine, any windows firewall advice at all please?

    ![file and print sharing.PNG](/public/imported_attachments/1/file and print sharing.PNG)
    ![file and print sharing.PNG_thumb](/public/imported_attachments/1/file and print sharing.PNG_thumb)



  • @karldonteljames:

    @karldonteljames:

    …and I have also tried to disable the windows firewall on both machines for testing....

    I've just restarted the media-centre and switched the firewall off, and it allowed connection from other machine. File and print sharing is already enabled on that machine, any windows firewall advice at all please?

    Allowing port 445 inbound on the windows firewall did the trick.
    Sorry for the useless post. Maybe someone else will find it useful someday!


Log in to reply