How to setup captive portal with my linksys router



  • Hi guys.

    Please help me. I want to setup captive portal on my linksys router,
    I already connect my linksys router in pfsense, opt port.

    current router config,

    disable dhcp and set it to bridge mode.
    so far its working fine.

    but when i tried to setup captive portal, it doesnt work.

    how do i setup it?

    please help me.



  • I guess I can help.

    I'm using a portal network with 4 Linksys devices like some WRT54GS…. and several E1200.
    The minute I open the box, I blow away the original firmware, and replace it with this : https://dd-wrt.com/site/index - but I guess the original firmware works just fine.

    Reset them complete.
    If your OPT1 interface has 192.168.2.1, use
    192.168.2.2 for the first AP
    192.168.2.3 for the second.
    etc
    Exclude this range from the pfsense OPT1 DHCP pool.

    For each AP :
    DNS = IP-OPT
    Gateway = IP-OPT.
    Shut down all other services, firewall's ... DHCP server, DNS server, whatever.
    (all this will take 60 - maybe 120 seconds).
    And hoppa, they will all work just fine. At least, some of mine work already for nearly a decade like that.

    Never-ever use the RJ45 port labeled WAN on these devices (they could work, but some special settings are needed).
    Use one of the four LAN ports to connect to a switch or directly to pfsense.

    But, as, always, RESET them, and then describe exactly EACH step** you took to a not working situation.
    We, on the forum, will tell you then immediately what you shouldn't do ;)

    ** omit a step and you'll be in for a hard time.



  • Hi Sorry for the late reply.

    this what i did for linksys router: I set Internet Settings to Bridged mode with static IP 192.168.100.2
    connected to my OPT1 with IP 192.168.100.1.

    in router wireless setup should I disable the security mode?



  • Hi,

    My OPT interface with Captive portal : 192.168.2.1

    See image for the main settings on my Linksys E1200 with DD-WRT.

    On the security page everything is disabled.




  • Hi Gertjan,

    Thanks for the reply, do you mind if I ask for screenshot of wireless settings.

    thanks a lot.



  • Certainly.




  • Thank you for the reply sir gertjan

    is your wireless security disabled?



  • Of course.
    I'm using the captive portal in a hotel - not at my home.
    The authentication is handled by the portal over TLS (htpps) already - no need to add another layer of security.
    After authentication, clients connect to Google, Facebook, or whatever other site over https also. Look at this forum, it's https also.
    Incoming and outgoing mail is not done over 110 and port 25 anymore? These have been replaced by ports 587 (Submission + TLS), if not 465 (SMTPS) and 995 (POPS) or 993 IMAPS).
    FTP is dead, its SFTP now.
    Etc.

    Clients who really need a secure connection all the time, like hiding all DNS traffic, IP addresses, whatsoever :  up to them to open up the access first on the Captive portal, and then they should kick in their VPN.

    Activating wifi encryption means I would have to communicate a login code, a password and SSID password. That's overkill - and complicates the process.



  • I followed your settings, but i cant go to login page.



  • Wifi is connected ?

    Run this on you PC:

    ipconfig /all
    

    When you disable the Captive portal, you have a connection to the net ?

    What firewall rules on OPT ?