Nordvpn OVPN working but unable to view Netflix, its blocked



  • it took about 3 days of trying to get nordvpn 256 abc setup and working on my sg2220.  it is working now basically following a PIA instruction but adding each IP of every machine to firewall > rules > lan.  then changing the gateway to the nord interface.

    tv has a static ip of 192.168.1.180.

    i went to firewall > rules > lan

    action =pass
    interface =lan
    address =ip4
    protocol =any

    source =ip of tv
    destination = any

    gateway = wan_dhcp.

    the TV from the browser actually shows my spectrum external address NOT the nordvpn ip address.  so i know it is setup properly.  but when i log netflix  it will not load it says its blocked due to origin.    Amazon prime opens and plays just fine.      4 hours into this and i am at a total loss

    any suggestions?  i have seen several youtube video's and i have followed them,  but it still does not work…

    this SAME setup workings with PIA with no extra changes,  Nordvpn i can not figure this out

    Nordvpn support is of no help whatsoever even from trying to get the initial setup to work.  they keep forwarding their directions that do not work at all.  i factory defaulted my unit 3 times and set it up from scratch and it did not work



  • i fixed my own issue right before i went to bed.  got up and tested it and it works!

    firewall > rules > lan > you must change the original ip4, lan net gateway to nordvpn gateway.  the exact OPPOSITE you would think.

    this now works.  i hope this helps someone else as this has been a headache

    Well it’s let me watch one show and now it’s causing problems, hopefully it’s just Netflix

    another update.    i undid all the settings in DNS resolver.  ultimatley the option under outgoing network interfaces.  i changed that to ALL it was on nordinterface

    i think its fixed now…



  • I just followed below mentioned setup and within 1 to 2 hours it was working fine for me.  Just Google "openvpn pfsense nordvpn"

    https://nordvpn.com/nl/tutorials/pfsense/pfsense-openvpn/

    I can confirm this setup is also working for PfSense 2.4.2

    In this setup you find "Auth digest algorithm: SHA1 (160-bit); (On newer servers, this would be SHA-512)"
    I needed SHA-512!!!

    There seem to be some NordVPN servers who can access Netflix. Can't help you here as I am not a Netflix customer.



  • Nordvpn woujd connect BUT no pc on the network could view pages…

    Very frustrating but right now it IS working just trying to get one TV to access the net across the wan gateway not the Nordvpn one

    Thank uk for replying At least I’ve heard of one person it was working for

    Their support was blaming DNS but it was setup 3 times according to their instructions and did not work



  • To be honest, the link I posted was working for me but all my traffic behind PfSense is routed through the NordVPN. I missed that you needed an exception for your TV. Merry Christmas.



  • after several more hours of this i have this working the way i required it.

    my cameras and tv are running on the gateway wan.

    all other devices are working through the nordvpn tunnel.      this has been an absolute nightmare.  i finally have a good backup to my cloud account of the console config backup…

    i also feel along the way with the support tickets i have sent to them they have fixed several issues they were having with servers and speed.  as of last night i am getting faster speeds than ever connected.

    i haven't changed anything but with my pictures of the config its just working better.

    i hope it stays this way.

    i ended up canceling my subscription to NORDVPN>  they could not give me the speeds they said were available on any of their servers.  i have those speeds through a difference provider


Log in to reply