OpenVPN service not starting after suddenly shutdown

  • Hi People!! I'm with a big problem im my business. After a power failure, the server went down and then when I power it on, the service of the OpenVPN says "Impossible to contact the daemon". I tried to connect on SSH and see the configuration if it's all right, but when I try to access the folder "/var/etc/openvpn" it says "Bad File Descriptor".

    The logs of the VPN and OpenVPN says nothing, and in the system logs it says "/vpn_openvpn_server.php: The command '/usr/local/sbin/openvpn –config '/var/etc/openvpn/server1.conf'' returned exit code '1', the output was 'Options error: In [CMD-LINE]:1: Error opening configuration file: /var/etc/openvpn/server1.conf Use –help for more information."

    I don't know what to do any more. Tried to create a new VPN, etc, but nothing works. Please, someone got this problem ever??


  • Rebel Alliance Developer Netgate

    Sounds like you have a low-level filesystem issue. Take a config backup before doing anything about it.

    You might be able to use the console reboot menu to run a fsck (disk check) for the next reboot, if that doesn't work you'll need to reboot to single user mode from the loader menu and then run "fsck -y /" a few times until it finds nothing wrong. Don't stop running it when it claims the disk has been fixed, it needs to be re-run until it finds no new problems.

    Worst case scenario, reinstall using the recover config.xml option to retain your existing settings.

Log in to reply