[Gelöst] Neues LAGG-Interfaces macht DHCP-Server-Konfiguration kaputt?



  • Hallo zusammen,

    folgendes Setup:

    • WAN

    • LAN

    • WLAN

    • SERVER (LAGG)

    Die DHCP-Configs für die einzelnen Interfaces sehen wie folgt aus.

    LAN:

    • Subnet: 192.168.1.0

    • Subnet Mask: 255.255.255.0

    • Available range: 192.168.1.1 - 192.168.1.254

    • Range: 192.168.1.100 - 192.168.1.199

    WLAN:

    • Subnet: 172.31.32.0

    • Subnet Mask: 255.255.255.0

    • Available range: 172.31.32.1 - 172.31.32.254

    • Range: 172.31.32.100 - 172.31.32.230

    SERVER:
    Ist ein LAGG aus 2x Interfaces via Roundrobin. Dort liegt auch das VLAN 10 drauf.
    Als Interfaces (Interfaces -> Assignments) habe ich "VLAN 10 on lagg0" ausgewählt.

    • Subnet: 10.10.10.0

    • Subnet Mask: 255.255.255.0

    • Available range: 10.10.10.1 - 10.10.10.254

    • Range: 10.10.10.10 - 10.10.100

    Aktiviere ich nun auf dem Interface "SERVER" den DHCP-Server, wird dieser mit folgender Meldung gestoppt.

    Jan 21 20:17:29 fw1 dhcpd: Internet Systems Consortium DHCP Server 4.3.6
    Jan 21 20:17:29 fw1 dhcpd: Copyright 2004-2017 Internet Systems Consortium.
    Jan 21 20:17:29 fw1 dhcpd: All rights reserved.
    Jan 21 20:17:29 fw1 dhcpd: For info, please visit https://www.isc.org/software/dhcp/
    Jan 21 20:17:29 fw1 dhcpd: Config file: /etc/dhcpd.conf
    Jan 21 20:17:29 fw1 dhcpd: Database file: /var/db/dhcpd.leases
    Jan 21 20:17:29 fw1 dhcpd: PID file: /var/run/dhcpd.pid
    Jan 21 20:17:29 fw1 dhcpd: Internet Systems Consortium DHCP Server 4.3.6
    Jan 21 20:17:29 fw1 dhcpd: Copyright 2004-2017 Internet Systems Consortium.
    Jan 21 20:17:29 fw1 dhcpd: All rights reserved.
    Jan 21 20:17:29 fw1 dhcpd: For info, please visit https://www.isc.org/software/dhcp/
    Jan 21 20:17:29 fw1 dhcpd: Wrote 0 deleted host decls to leases file.
    Jan 21 20:17:29 fw1 dhcpd: Wrote 0 new dynamic host decls to leases file.
    Jan 21 20:17:29 fw1 dhcpd: Wrote 1 leases to leases file.
    Jan 21 20:17:29 fw1 dhcpd: Interface igb1 matches multiple shared networks
    Jan 21 20:17:29 fw1 dhcpd: 
    Jan 21 20:17:29 fw1 dhcpd: If you think you have received this message due to a bug rather
    Jan 21 20:17:29 fw1 dhcpd: than a configuration issue please read the section on submitting
    Jan 21 20:17:29 fw1 dhcpd: bugs on either our web page at www.isc.org or in the README file
    Jan 21 20:17:29 fw1 dhcpd: before submitting a bug.  These pages explain the proper
    Jan 21 20:17:29 fw1 dhcpd: process and the information we find helpful for debugging.
    Jan 21 20:17:29 fw1 dhcpd: 
    Jan 21 20:17:29 fw1 dhcpd: exiting.
    
    

    Schauen wir also beim Interfaces nach..

    [2.4.2-RELEASE][admin@fw1.localdomain]/root: ifconfig igb1
    igb1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    	options=6400bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso,rxcsum_ipv6,txcsum_ipv6>ether 00:30:18:01:df:32
    	hwaddr 00:30:18:01:df:32
    	inet6 fe80::230:18ff:fe01:df32%igb1 prefixlen 64 scopeid 0x2 
    	inet 192.168.1.254 netmask 0xffffff00 broadcast 192.168.1.255 
    	inet 10.10.10.1 netmask 0xffffffff broadcast 10.10.10.1 
    	nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (1000baseT <full-duplex>)
    	status: active</full-duplex></performnud,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso,rxcsum_ipv6,txcsum_ipv6></up,broadcast,running,simplex,multicast> 
    

    Jemand eine Idee, wie ich das "falsche" Subnet dort rausbekomme?
    Interfaces habe ich bereits neu abgespeichert.

    Viele Grüße,



  • Hi,

    ich würde sagen du solltest die Firewall mal rebooten und schauen ob das da ist.
    pfSense sagt selber wenn man LAGG Interfaces anlegt oder löscht kann es zu einem Reboot kommen und das man danach neu starten soll.

    Ansonsten würde ich schauen ob du statt des VLAN10 ein Alias angelegt hast.
    Es muss ein igb1.10 geben wo seine IP von vlan10 drauf liegen muss.

    Gruß blex



  • Hi,

    reboot tut immer gut! :)
    Konfig funktioniert nun.

    Vielen Dank und schönen Abend,



  • Bitte schön  ;D


Log in to reply