Memory Allocation Errors



  • Hi!  I added a couple more lists to my pfblocker install and now am seeing the memory allocation error…

    PHP ERROR: Type: 1, File: /usr/local/pkg/pfblockerng/pfblockerng.inc, Line: 2496, Message: Allowed memory size of 536870912 bytes exhausted (tried to allocate 8192 bytes)	@ 2018-01-24 17:44:39
    Close
    

    I have 8 gigs of memory in the box at 19% utilized, and 0% swap used out of 16gb.  I was wondering if this is a fluke, or if I should change something around so that I'm not seeing this error.

    Versions:
    pfsense: 2.4.2-RELEASE-p1 (amd64)
    pbBlockerNG: 2.1.2_2

    Thanks!



  • @BBcan177:

    Just clear the notice for now… I suspect that it doesn't repeat once you clear it...

    Can you try the following patch?
    https://forum.pfsense.org/index.php?topic=110515.60

    The next version of the package has a new function that will improve this issue from repeating...

    Thanks!



  • @RonpfS:

    @BBcan177:

    Just clear the notice for now… I suspect that it doesn't repeat once you clear it...

    Can you try the following patch?
    https://forum.pfsense.org/index.php?topic=110515.60

    The next version of the package has a new function that will improve this issue from repeating...

    Thanks!

    Thanks, I'm going to give it a shot.  I'm glad I scrolled down in that thread to see how easy the patch manager is to use in pfsense.  :)  I was going to do it by hand.



  • Based on reading that thread it seems like it should be cleared up. I'm on 2.4.3 and 2.1.2_2. SG3100.  Every time I clear it I see it again the next time I login.

    PHP ERROR: Type: 1, File: /usr/local/pkg/pfblockerng/pfblockerng.inc, Line: 2496, Message: Allowed memory size of 134217728 bytes exhausted (tried to allocate 8192 bytes)
    


  • pfSense 2.4.3 I have the same issue after updating to this version.
    Also My VAR usage goes from like 200mb to 2GB.
    The PHP message repeats every 2-3 days consistently.
    Interestingly restarting does not fix my var usage, If i restart my openvpn client deamon then the var usage goes back down. I am using ram disks btw and would like to allocate less ram to my pfsense vm but this error prevents me from doing so.


  • Moderator



  • Ive been running the Devel release for a week + now and seems to be good. Thanks!



  • I see 2.2.1 devel is now listed in my available packages. Running latest stable.


Log in to reply