Porblema Squid + NTLM authentication + Starting new negotiateauthenticator helpe



  • Buenas tardes,

    Tengo instalado squid + squidguard + pf2ad instalado y configurado.

    Desde hace poco me ha empezado a ocurrir algo curioso. Cuando tengo que añadir algún dominio en una de las "GROUP ACLS" por ejemplo, y doy en "APPLY", la configuración se guarda, pero squid deja de hacer reenvios, teniendo que reiniciar el servicio de squid tambien.

    Con anterioridad, con solo darle a "APPLY" en squidguard, era suficiente.

    Este problema también pasa cuando reinicio el servidor por algún motivo, squid no ejecuta los new negotiateauthenticator helpers y muestra esto dentro del realtime en el servicio de squid proxy server

    01.02.2018 16:20:38	Select loop Error. Retry 1
    01.02.2018 16:20:33	Service Name: squid
    01.02.2018 16:20:33	Starting Squid Cache version 3.5.27 for amd64-portbld-freebsd11.1...
    01.01.1970 01:00:00	
    01.01.1970 01:00:00	
    01.01.1970 01:00:00	
    01.02.2018 16:19:29	Shutdown: Basic authentication.
    01.02.2018 16:19:29	Shutdown: Digest authentication.
    01.02.2018 16:19:29	Shutdown: Negotiate authentication.
    01.02.2018 16:19:29	Shutdown: NTLM authentication.
    01.02.2018 15:52:45	Select loop Error. Retry 1
    01.02.2018 15:52:41	Service Name: squid
    01.02.2018 15:52:41	Starting Squid Cache version 3.5.27 for amd64-portbld-freebsd11.1...
    01.02.2018 15:52:39	Creating missing swap directories
    

    En ese caso, si también reinicio el servicio de squid, funciona correctamente.

    Me pasa con un entorno en version 2.3.4, y en la ultima versión de pfsense con todos los paquetes actualizados a la ultima versión.

    Un saludo.



  • Buenos días,

    Ye he encontrado solución. El problema es que en la cadena de "define('REDIRECTOR_PROCESS_COUNT', '128 startup=32 idle=4 concurrency=0')" en el apartado startup puse 256 y no debe de gustarle tantos procesos al inicio.

    Un saludo.


Log in to reply