Problema al validar usuario con el AD usando LDAP



  • Problema al validar usuario con el AD usando LDAP

    Buenas tardes Amigos, Actualmente estoy usando la Version 2.4.1-RELEASE (amd64). tengo instalado y configurado Squid, Squid Guard. con la intención de autenticar en los equipos la navegación con los usuarios del Active directory. la he configurado inclusive desde pfsense puedo autenticar todos los usuarios de los grupos creados con exito. el problema lo tengo al momento de autenticarme en los equipos clientes. queda en blanco y no me da ningún resultado. agradezco su colaboracion en la culminacion de este proyecto. Actualmente uso Windows Server 2008R2



  • y en el navegador cuando intentas navegar pide las credenciales de Windows?



  • Primero: Squid Autentica

    Segundo: SquidGuard decide en que pagina navegas.

    Partiendo de lo anterior, quita o deshabilitar squidguard, dejalo solo con Squid y prueba la autenticación.

    De funcionar (que al abrir el navegador te autenticas y navegas), certificas squid, entonces no lo tocas mas.

    Alli viene ahora el Squidguard, valida los query de busqueda por grupos y el usuario que autentica para el squidguard, trata que los grupos del AD no tengan espacios, todo para facilitar la linea de configuración.



  • Buenos días estimados, Saludos para todos!!

    Requiero de su ayuda, tengo una semana preparando un Proxy (v2.4.3) con LDAP para autenticar los usuarios del Dominio y me solicita las credenciales al colocar cualquier URL sin exito el acceso a Intenet, sin embargo, en principio había agregado mi dirección IP "Unrestricted IPs" y si me da acceso a Internet.

    Luego agregue Samba (https://github.com/pf2ad/pf2ad) usando el comando: fetch -q -o - https://raw.githubusercontent.com/pf2ad/pf2ad/2.4.3-SAMBA4/pf2ad.sh | sh

    Al configurarlo, ahora no me deja navegar ni siquiera teniendo mi IP en "Unrestricted IPs" y aún me sigue solicitando las credenciales.

    La única forma que puedo navegar, es configurándolo en modo Transparente por el Proxy Port en 8080

    Proxy filter SquidGuard:

    Common ACL:
    URL permitidas para todos los usuarios [Base] access [whitelist]
    [blk_BL_****************]         access [deny]
    Default [all]                 access [deny]

    Groups ACL:

    Disabled  Name               Description
    on   Basico               SG.Pxy.Basico
    on   Administrativo      SG.Pxy.Administrativo
    on   Avanzado       SG.Pxy.Avanzado
    on   VIP       SG.Pxy.VIP

    Target categories:

    Name Description
    Base         Permitir acceso a todos los Usuarios
    Bancos-Seguros Permitir acceso a Banco y Seguros
    SitiosBloqueados No permitir acceso a todos los Usuarios
    RedesSolicales Permitir acceso a Redes Solicales
    Noticias         Permitir acceso a Sitios de Noticias
    Empresas         Permitir acceso a Sitios de Empresas
    Correo Permitir acceso a al Correo GMAIL

    DiagnosticsAuthentication: User UsuarioPrueba authenticated successfully. This user is a member of groups:

    SG.Pxy.Admin



  • Hi j.sejo1

    I did the steps indicated and still ask me for authentication, squid is not certified.

    Regards,

    Richard