Failed basic FreeRADIUS and Captive portal setup



  • The Subject title may look trivial and repeated, also you might think this is another ordinary issue about setting up FreeRADIUS + Captive portal. All I can assure is I’ve been testing the steps used to setup the configuration very carefully and still can’t find a solution. That’s why I am here. I have collected several screenshot images in order to provide further info.

    Software version:
    –----------------------------------------------------------------------------------
    pfSense        2.4.2-RELEASE
    freeradius3    0.15.4                            (Packet Manager)

    Summary: My boss asked me to setup a wireless hotspot at the company I currently work. I have been using pfSense for a couple years and I also was working in an institution that had a RADIUS server + pfSense + Portal captive service. The difference there was the RADIUS server runs under Windows Server so all I have to do is replace Windows Server RADIUS for FreeRADIUS embedded on pfSense (packet freeradius3 v0.15.4). My next step was gathering some info about this settup and surprisingly for me I found some videos on YouTube about doing this. The videos are https://www.youtube.com/watch?v=qCTsyW65WbA and https://www.youtube.com/watch?v=qCTsyW65WbA. The configuration in both is very straight forward and fast, my opinion though.

    Technical information:
    –--------------------------------------------------------------------------------------------------------------------------------------

    • IPv4 for pfSense: WAN 10.10.10.253 and LAN 10.10.11.254  (LAN interface will be named WIFI)
    • IPv4 for FreeRADIUS: 10.10.11.254 (running on pfSense)
    • DHCP enabled and tested correctly on WIFI interface 10.10.11.10 - 10.10.11.230

    ** Before installing freeradius3 and trying to set up the captive portal, devices from WIFI network were able to reach every (rules) service on main subnet such as jabber (XMPP), POP3, SMTP, etc…

    Network schema

    After installing freeradius3 (System -> Packet Manager) and configure it following the YouTube tutorials before mentioned I got no response when trying to access any site. I mean, no Captive portal was prompted. So I decided to start diagnosis doing port test (Diagnostics -> Test port).

    This is the response for FreeRADIUS (1812) availability check. I don’t know if pfSense performs this action using TCP or UDP or both, so I also tried using PortQryUI which allows doing boths and still got nothing. This is the output from pfSense Test port.

    As the picture shows, pfSense can’t find any open port for 1812, however in dashboard says radiusd (FreeRADIUS server) service is running. Finally I found in System -> Packet Manager that Installed packets was showing an unusual warning. I have to say that I tried with the IPv4 addresses 127.0.0.1 10.10.11.254 and 10.10.10.253 for testing the port.

    During the freeradius3 packet installation I got no problem, no warning, even saw Success at the end of installation. I have deleted the packet, installed again, reinstalled the pfSense OS and started again and still the freeradius3 issue persists. Is there a problem with this packet or it is just me? The topic says FreeRADIUS and Captive Portal by I guess the problem lies in freeradius3 packet.



  • OHH the forum isn’t showing the imgur images!!


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy