WebConfigurator fails to open when no WAN 2.4.2.RELEASE-p1 (amd64)



  • I noticed strange problem when I start firewall without WAN connection.
    If that is done I can't access WebConfigurator at all.

    I try to Restart WebConfigurator and I see error messages:

    
    Message from syslogd@siwall at Jul 24 06:24:44 ...
    fwall nginx: 2017/07/24 06:24:44 [emerg] 36058#100610: bind() to 0.0.0.0:80 failed (48: Address already in use)
    

    Funny thing is that you can ping LAN interface, you can use SSH, you get IP -address but WebConfigurator is not working. That means only that PHP has somekind of panic with addresses and refuses to load WebConfigurator.

    After I put back WAN to online - the WebConfigurator  does NOT return to its normal automatically - I must be Restarted and then it works like charm again. Now if I remove WAN from online - no problems with WebConfigurator, but if I  start or reboot in this stage - I'm screwed. No way to access WebConfigurator .

    This happens ONLY when I have DHCP in use in WAN. No problems if I just have any IP on WAN interface without any gateways and dns servers.

    Is there any work around to fix this?



  • @Clouseau:

    …..
    Is there any work around to fix this?

    Yep.
    Telling us more / the whole story.

    The error says that an instance of the GUI is already running, thus the 'bind' error - but probably not in a good shape.

    Check out the logs files after booting. Something must show up that is not "normal".

    edit : I can rip out the WAN cable (WAN connection for me is a DHCP client, connected to an up stream ISP router) and this does not break my GUI.
    pfSense works just fine (well, sort of) without an enabled WAN connection, because,remember, when pfSense was started the very first time, right after you installed it, there was NO WAN connection setup, and you had to use the GUI to setup LAN first.


Log in to reply