Cannot access WebGui through any browser

  • Hi All,

    I havnt touched my PFSense box for a while and i needed to last night and discovered i cannot access the webgui. When i access it with Firefox 58.0.2 i get

    Secure Connection Failed

    The connection to the server was reset while the page was loading.

    The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
        Please contact the website owners to inform them of this problem.

    I`ve tried Chrome,Edge and Internet explorer and all give me the same warning or close to it. I thought it was an OS version problem so i jumped onto the CLI through Putty and was performed an upgrade but after the upgrade the same problem occurred.

    The CLI is working fine i just cannot get to the WebGui. I really dont want to factory reset as i had a whole heap of rules in place and as dumb as i feel i dont recall then last backup i committed but then restoring from a backup could present this problem again.

    Anyone have any tips? I tried changing the viconfig webgui line from https to http but im not sure if pfsense is using vi as i couldnt insert to edit the config

    *** Welcome to pfSense 2.4.2-RELEASE-p1 (amd64) on pfSense ***

    WAN (wan)      -> bge0      -> v4:
    LAN (lan)      -> bge1      -> v4:

    1. Logout (SSH only)                  9) pfTop
    2. Assign Interfaces                10) Filter Logs
    3. Set interface(s) IP address      11) Restart webConfigurator
    4. Reset webConfigurator password    12) PHP shell + pfSense tools
    5. Reset to factory defaults        13) Update from console
    6. Reboot system                    14) Disable Secure Shell (sshd)
    7. Halt system                      15) Restore recent configuration
    8. Ping host                        16) Restart PHP-FPM
    9. Shell

    Enter an option:


  • Hello. This looks like you just need to add exception to trust this page's certificate (when you see this on firefox, there is blue button Add exception, must be similar in other browsers). AFAIK, this is because pfsense's certificate for that page is self-signed, and you have no way to check the trust for you with that kind of certs.

    Other option is to revert webGui to http, it's available in CLI option 2 (set interface's ip), but I guess the abovementioned way is better.

  • Thanks for the reply das_remsem, i tried everything you mentioned and still the same issue. I`ve been working on it a few hours this weekend and connected a monitor and keyboard to the router. i tried re-installing PFSense and it wouldnt take so i used Dban to format the disk. Re-installed and the same problem. I have my work Surfacebook home with me so i fired it up and it worked. I was able to hit the web GUI no problems. I wasnt too sure what else to do so i quickly install LinuxMint in HyperV on my PC and used that to re-configure the router. I tested the WebGui again from my pc and the same problem, i just so happened to click on the SSL error and looked into the certificate and noticed that it was sitting under a BitDefender container like BitDefender Free was dealing with the certificate. I uninstalled BitDefender Free and the Gui is now working in every browser like it initially was. Quite strange but i figured it out and hopefully others who may be having the issue can use this as a resolution should they have BDFree installed.


Log in to reply