Blocked page by Squid Proxy is not Squid's default page



  • Hello,

    I have installed and setup Squid Proxy and SquidGuard and blocked some categories in Common ACL. I enter websites which I blocked, blocked page contains following sentences:

    400 Bad Request
    The plain HTTP request was sent to HTTPS port
    nginx

    But I want Squid default blocked page to be shown to users like in the second attached picture. How can I do it?





  • how to even get the behavior on the second pic? I thought HTTPS sites couldn't show the squid error page.

    For the first problem:

    try to modify the option protocol inside webConfigurator located in System/Advanced/Admin Access. Change it to HTTP (not advised but I don't know how else to bypass it)



  • The second picture is Squid's default page blocked which I have found on google.
    The problem is when I check WebGUI redirect, Squid replaces default block page with 400 Bad Request.

    Changing HTTPS TO HTTP is not insecure?



  • @emammadov:

    The problem is when I check WebGUI redirect, Squid replaces default block page with 400 Bad Request.

    If you enable webgui redirect, all requests for the pfsense ip will go through port 80 (HTTP), I guess nginx does not like it when HTTPS traffic goes through there.

    @emammadov:

    Changing HTTPS TO HTTP is not insecure?

    Yes, but I don't know how else to get pfsense to show the error page on HTTP sites with squidguard. If I select HTTPS, I get your first error image.

    I need guidance too.



  • Thank you for your reply. I leave it as it is.
    In TCP Port, section is empty. Default 80 for HTTP, 443 for HTTPS. How can I add two port in the same section? It only allows one port number. If I add for example 445, then it should apply both?


Log in to reply