Squid guard does not work



  • Hi everyone, I'm new to pfsense and I need to restrict access to web pages by categories, and install the squid and squid guard but do not filter it that I'll be doing wrong.

    I attach images of the configuration that I have in my squid and squid guard.

    I do not have the proxy settings on my PC. and I want that I do not have to add the ip of my proxy in each equipment so that it can filter the content if there is some way please tell me.


    ![squid 2.png](/public/imported_attachments/1/squid 2.png)
    ![squid 2.png_thumb](/public/imported_attachments/1/squid 2.png_thumb)
    ![squid guard.png](/public/imported_attachments/1/squid guard.png)
    ![squid guard.png_thumb](/public/imported_attachments/1/squid guard.png_thumb)
    ![squid guard 2.png](/public/imported_attachments/1/squid guard 2.png)
    ![squid guard 2.png_thumb](/public/imported_attachments/1/squid guard 2.png_thumb)
    ![squid guard 3.png](/public/imported_attachments/1/squid guard 3.png)
    ![squid guard 3.png_thumb](/public/imported_attachments/1/squid guard 3.png_thumb)
    ![squid guard 4.png](/public/imported_attachments/1/squid guard 4.png)
    ![squid guard 4.png_thumb](/public/imported_attachments/1/squid guard 4.png_thumb)



  • Hello. In Squid General settings, enable Transparent HHTP proxy.
    In SquidGuard / Common ACL deny the categories which you wish to block and at the end allow "Default access (all)".
    Note this will only apply HTTP websites. If you wish SquidGuard to filter SSL websites as well, you have enable SSL filtering in Squid and export CA certificate from pfSense and import that certificate into each device you want.



  • Hello, I have already configured it in transparent mode but it still does not block the squid guard, I do not know if I have something wrong configured, now with what you say about HTTPS, the CAs certificate I believe it, I import it because it shows me a form to create import and if I do not configure that it does not let me enable the Enable SSL filtering option.

    ![squid guard.png](/public/imported_attachments/1/squid guard.png)
    ![squid guard.png_thumb](/public/imported_attachments/1/squid guard.png_thumb)
    ![squid guard 2.png](/public/imported_attachments/1/squid guard 2.png)
    ![squid guard 2.png_thumb](/public/imported_attachments/1/squid guard 2.png_thumb)


Log in to reply