Client Not Getting Gateway



  • Hello friends,

    Im having the following trouble with OpenVPN client:

    - I can access to my LAN properly and stuff, i also can get internet access.
      - When i do on windows the command "ipconfig" it displays the client gets the proper IP and Mask but no "GATEWAY" assigned it is just in blank.

    Im just starting on this, but i assume i have internet access trough the current WAN im connected and not trough pfsense, and what i want to do is to route X client traffic trough my pfsense.

    Help me please.

    Thanks.



  • Check "Redirect gateway" in the server settings.



  • @viragomann:

    Check "Redirect gateway" in the server settings.

    I did add the  push "redirect-gateway def1"    to the box but it does nothing.



  • With "Redirect gateway" checkt, the client should get pushed the default route.
    However, the default route is split in two parts:

    0.0.0.0/1        <ovpn-server>128.0.0.0/1</ovpn-server> 
    

    That's why the OS doesn't see the vpn server as default gateway.

    So check the clients routing table or try a traceroute to a public address to verify if you go over vpn.



  • @viragomann:

    With "Redirect gateway" checkt, the client should get pushed the default route.
    However, the default route is split in two parts:

    0.0.0.0/1        <ovpn-server>128.0.0.0/1</ovpn-server> 
    

    That's why the OS doesn't see the vpn server as default gateway.

    So check the clients routing table or try a traceroute to a public address to verify if you go over vpn.

    Im still not getting the gateway :(
    Well i attach my routing table here:




  • @viragomann:

    With "Redirect gateway" checkt, the client should get pushed the default route.
    However, the default route is split in two parts:

    0.0.0.0/1        <ovpn-server>128.0.0.0/1</ovpn-server> 
    

    That's why the OS doesn't see the vpn server as default gateway.

    So check the clients routing table or try a traceroute to a public address to verify if you go over vpn.

    Nevermind!, i ran a "tracert" command to "X" public IP and i noticed it is going trough my VPN server, i also checked on http://www.whatsmyip.org/ and i had my VPN server public IP.

    Thanks for the tip !


Log in to reply