Multi WAN Offline nicht mehr alleine Online



  • Hallo,

    ich habe bei meiner PFsense Multi WAN für Failover. Nun habe ich das Problem wenn auf WAN1 die Internetverbindung ausfällt, also praktisch Loss 100% erreicht ist, die Pfsense von alleine nicht mehr auf WAN1 zurückschaltet. Ich muss dann jedesmal den WAN1 Port deaktivieren und aktivieren dann geht es wieder.

    Also die Umschaltung von WAN1 auf WAN2 funktioniert aber zurück nicht mehr wenn dann WAN1 wieder verfügbar ist.

    Anscheinend findet sobald der WAN1 ausfällt keine erneute Überprüfung mehr statt.

    Hat jemand Erfahrung damit?

    Eingestellt ist es so:

    13:37 Internetausfall durch abstecken der Zuleitung zum Modem gemacht
    14:00 internet auf WAN1 wieder verfügbar

    System Logs:

    Feb 27 13:37:48 rc.gateway_alarm 91471 >>> Gateway alarm: WAN1GW (Addr:8.8.4.4 Alarm:1 RTT:18713ms RTTsd:4408ms Loss:22%)
    Feb 27 13:37:48 check_reload_status updating dyndns WAN1GW
    Feb 27 13:37:48 check_reload_status Restarting ipsec tunnels
    Feb 27 13:37:48 check_reload_status Restarting OpenVPN tunnels/interfaces
    Feb 27 13:37:48 check_reload_status Reloading filter
    Feb 27 13:37:50 php-fpm 5341 /rc.dyndns.update: Default gateway down setting WAN2_PPPOE as default!
    Feb 27 13:37:50 php-fpm 5341 /rc.dyndns.update: MONITOR: WAN1GW is down, omitting from routing group DualWAN 8.8.4.4|192.168.100.2|WAN1GW|18.747ms|4.479ms|25%|down
    Feb 27 13:37:50 php-fpm 5341 /rc.dyndns.update: Default gateway down setting WAN2_PPPOE as default!
    Feb 27 13:37:50 php-fpm 65471 /rc.openvpn: OpenVPN: One or more OpenVPN tunnel endpoints may have changed its IP. Reloading endpoints that may use WAN1GW.
    Feb 27 13:37:50 php-fpm 65471 /rc.openvpn: Default gateway down setting WAN2_PPPOE as default!
    Feb 27 13:37:50 php-fpm 65471 /rc.filter_configure_sync: Default gateway down setting WAN2_PPPOE as default!
    Feb 27 13:40:20 php-fpm 11774 /services_dyndns.php: Default gateway down setting WAN2_PPPOE as default!
    Feb 27 13:40:24 check_reload_status Syncing firewall
    Feb 27 13:40:24 php-fpm 11697 /services_dyndns.php: Default gateway down setting WAN2_PPPOE as default!
    Feb 27 14:11:47 check_reload_status Syncing firewall
    Feb 27 14:11:47 check_reload_status Reloading filter
    Feb 27 14:11:48 php-fpm 23963 /rc.filter_configure_sync: Default gateway down setting WAN2_PPPOE as default!
    Feb 27 14:20:59 check_reload_status Syncing firewall
    Feb 27 14:20:59 check_reload_status Reloading filter
    Feb 27 14:21:00 php-fpm 34668 /rc.filter_configure_sync: Default gateway down setting WAN2_PPPOE as default!
    Feb 27 14:24:10 check_reload_status Syncing firewall
    Feb 27 14:24:10 check_reload_status Reloading filter
    Feb 27 14:24:11 php-fpm 5833 /rc.filter_configure_sync: Default gateway down setting WAN2_PPPOE as default!



  • Ich kenne mich mit Multi-WAN nicht besonders gut aus, aber gibt es einen Grund, warum du keine Gateway-Groups benutzt?


  • Moderator

    Macht er doch - ist doch oben zu sehen.

    @lobi: Warum hast du default GW Switching überhaupt drin? Das ist doch für den normalen Anwendungsfall überhaupt nicht nötig und relevant!? Die GW Gruppe ist dafür da, das hin- und her switching abzubilden. Und mit der hatte ich bei MultiWAN noch selten Probleme.

    Gruß