Pfsense + Squidguard clean install. Squidguard won't start



  • Hi,

    Although I have googled and seen several similar topics, I haven't found a solution yet. Hopefully somebody can give some advice.

    • pfSense 2.4.2-RELEASE-p1 (arm) on Netgate SG-3100
    • SquidGuard 1.16.4
    • Under 'General settings'-tab I entered the Balcklist URL : http://www.shallalist.de/Downloads/shallalist.tar.gz + clicked 'Download'
    • Under 'target directories'-tab I create a dummy category
    • Under 'Common ACL'-tab I selected some categories from the categories including my dummy category.
    • Under 'General Settings'-tab I enabled squidguard and tried to start. But it remains in SquidGuard service state: STOPPED
    • In the log I see that I starts and immediately stops.

    06.03.2018 21:41:21    squidGuard stopped (276.1520368881)
                06.03.2018 21:41:21     db update done
                06.03.2018 21:41:21     squidGuard 1.4 started (1520368881.000)

    • No specific entires in the system > general log. Or should I enable specific squidGuard logging somewhere?

    Can someone please advise? Reinstalled may times.

    Aditional question : I supose that squidguard automatically installs all its dependencies when installing from the pfSense package manager? I do not have to install Squid separately?

    Thx!

    Thomas.



  • Solved it.

    apparently you first need to install squid and then squidguard.
    In squid proxy server : go tob tab 'local cache' + adjust hard disk cache size + save
    the go to tab 'general, click 'enable transparent mode' and then enable the squid proxy.

    That did it for me. SquidGuard started fine.



  • Squidguard is a helper app that takes URLs from squid and processes them in realtime as they're requested by the user.  You definitely need squid installed first.