OpenVpn home to sede



  • Ciao ho una rete con pfsense con openvpn configurata in modo che da un client pc da casa ad esempio possa collegarsi alla sede  , eseguendo appunto il client openvpn

    tutto funziona ma c’e’ un problema sui dischi condivi

    ovvero

    se il disco di rete lo mappo \nomeserver\share , dalla rete aziendale funziona ma da casa no non si connette
    se invece lo mappo \192.168.0.1\share , cosi’ funziona benissimo

    e’ come se da esterno non passano i nomi

    e’ un limite della vpn oppure ho sbagliato qualcosa io

    grazie



  • controlla la configurazione dei DNS



  • il dns e’ su server 2008, faccio nslookup e funziona tutto correttamente
    cosa dovrei controllare?



  • Nella configurazione della VPN hai specificato quale DNS devono utilizzare i client che si connettono?



  • a ok, pero’ prima di toccarla , visto che funziona volevo esserne sicuro

    vado in OPENVPN/SERVERS/EDIT

    nella zezione tunnel settings ho ip4 tunnel network e ip4 local network

    piu’ sotto ho advancend settings

    li ho queste voci :
    DNS Default Domain
    DNS Server enable
    Block Outside DNS
    Force DNS cache update
    NTP Server enable
    NetBIOS enable

    per logica mi viene da abilitare DNS Default Domain e scrivere l’ip del mio DNS interno, corretto cosi’?



  • Sì. Note bene che la sub-net dei client in VPN riescano a raggiungere l’IP dove risiede il DNS.
    Puoi fare comunque un backup prima!



  • ciao ho provato ma niente, non si connette come \NOMESERVER\SHARE ma come \indirizzo Ip\SHARE

    raggiungere lo raggiunge il client anche perche’ il DNS server e’ nela stessa sub net dei server e pfsense quindi raggiunge tutti tranquillamente

    in pratica non passano i nomi host

    ad esempio anche con desktop remoto se metto nome server non va se metto ip server va



  • Mi era capitata una cosa simile tempo fa…. non ricordo come avevo risolto ma avevo questo errore…

    iMac con TunnelBlick … se mi connettevo funzionava tutto ma non risolveva i DNS
    Virtualizzavo Windws con OpenVPN funzionava tutto, ma a volte non risolveva i DNS, mi scollegavo, mi ricollegavo un attimo dopo e funzionava!


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy