DNSBL not working, easylist works



  • Hello,

    I'm trying for over a week now but can't find a mistake/solution. Could be that it is trivial, since I'm quite new to those things.
    I want to use pfBlockerNG as substitute for my pi-hole, also using the same lists, but it doesn't block at all. Easylist on the other hand works.

    I attached some screenshots for my settings.

    As DNS Server I use the pfsense IP for any machine. Pinging and visiting the VIP works.


















  • screen 2 - select all checkbox except disable maxmind

    screen 3 -
    interface/rule configuration:
    outbound firewall rules:  select all LAN/VPN
    select floating rule and kill states

    screen 4
    select enable tld
    firewall rule > select all LAN’s
    list action > disable

    screen 7
    am not sure your gateways, but it should be
    network interface > LAN and localhost
    outgoing network interface > ALL OUTGOING, including VPN
    (or just select all on both interface.)

    then go to update and run force reload.



  • Thanks for the reply.

    tried your settings, but they do not work  :-[
    Any idea how to troubleshoot it?



  • Turn on Global logging, for debugging purposes, and try inbound and outbound on just the LAN for starters

    Choose the 2nd or 3rd "Rule Order" option so all your firewall pass rules are evaluated first

    pfBlockerNG rules on the WAN can complicate updates

    I prefer floating rule sets

    my 2 cents


Log in to reply