Pacote não oficial E2guardian v5 para software pfsense®



  • @raffaD11 Sim, estou com o mesmo problema já tem um tempo e não só na instalação mas como também para salvar as alterações realizadas nas abas de configurações do e2guardian. Ocorreu depois de eu atualizar a versão e agora pelo que vi já existe um novo update porém estou pensando se devo tentar atualizar ou não para ver se resolve este problema, pois mesmo aparecendo estes erros nos logs o e2 está funcionando normalmente porém estou realizando as configurações necessárias diretamente através do prompt.



  • @SNOWS said in Pacote não oficial E2guardian v5 para software pfsense®:

    @SNOWS said in Pacote não oficial E2guardian v5 para software pfsense®:

    @marcelloc Olá Marcelo obrigado pelo retorno mas não observei nenhum padrão de passos que poderia estar causando este erro, unica coisa que fiz foi realizar o update do PFSENSE da versão 2.4.2_1 para 2.4.4_3 e em seguida reinstalei o E2guardian na ultima versão e depois o SARG. Sendo assim após atualizar os pacotes fui tentar realizar a remoção de um IP do bypass e já me apareceu este erro. Aparentemente tudo continuou funcionando normalmente, porém ainda me aparecem erros no logs do sistema mesmo sem tentar alterar as configs do e2guardian. Não removi nenhuma config padrão das ACLS.

    Segue abaixo o erro apresentado hoje, nao consigo encontrar o motivo do mesmo.

    [01-Jul-2019 09:18:46 America/Sao_Paulo] PHP Fatal error: Uncaught Error: Cannot create references to/from string offsets in /usr/local/pkg/e2guardian.inc:71
    Stack trace:
    #0 /usr/local/pkg/e2guardian.inc(666): e2g_check_sched('Always active')
    #1 /etc/inc/pkg-utils.inc(707) : eval()'d code(1): sync_package_e2guardian()
    #2 /etc/inc/pkg-utils.inc(707): eval()
    #3 /etc/rc.start_packages(63): sync_package('E2guardian5')
    #4 {main}
    thrown in /usr/local/pkg/e2guardian.inc on line 71

    @marcelloc Fazendo mais testes percebi que em diversas abas quando realizo alteração nas configurações do e2guardian quando tento salvar aparece o mesmo erro do PHP. O e2guardian está funcionando porque quando reinstalei o pacote ele utiliza o arquivo de config que ja estava da versão anterior, porém não consigo realizar alterações que me aparece este mesmo problema ao tentar salvar. Poderiam me ajudar por favor? Obrigado.

    Olá! Conseguiu resolver este problema?



  • @SNOWS said in Pacote não oficial E2guardian v5 para software pfsense®:

    @raffaD11 Sim, estou com o mesmo problema já tem um tempo e não só na instalação mas como também para salvar as alterações realizadas nas abas de configurações do e2guardian. Ocorreu depois de eu atualizar a versão e agora pelo que vi já existe um novo update porém estou pensando se devo tentar atualizar ou não para ver se resolve este problema, pois mesmo aparecendo estes erros nos logs o e2 está funcionando normalmente porém estou realizando as configurações necessárias diretamente através do prompt.

    No caso, estou com esse erro na instalação. Fiz tudo recentemente em ambiente de testes e funcionou perfeitamente. Agora, nem deixa instalar ao apresentar esse erro!



  • @raffaD11 Sigo procurando solução. Qualquer novidade te informo.



  • @SNOWS Ok, caso eu ache publico por aqui também. Obrigado e boa sorte!



  • Bom dia a todos.

    pessoal, aqui por esse forum, graças a atenção e ajuda de todos, estou com meu pfsense +E2G funcionando perfeitamente, bloqueando, ontem também instalei o Sarg, apanhei um pouco mais consegui faze-lo, porem gostaria de alguma informação.

    quando gero o relatório do Sarg, vem os Ip´s que solicitaram as requisições no Pfsense, porem gostaria de que, esses ip´s fosse o nome do usuário do meu AD, ja vi alguns vídeos, comentários e varias outras informações, porem nao consigo entender como fazer para que meu pfsense traga no relatório para mim o nome do usuario ao inves do IP, alguém tem algum material para que eu possa estudar aqui para implementar mais essa funcionalidade no meu PFsense.

    também em tempo real, onde monitora todas as conexões atuais, também gostaria de transformar o IP em nome do usuário.



  • @diogenescorrea desculpa a demora no retorno.
    São dois Alias, um com os IPs e outro com os Hosts.
    Estes dois Alias vc insere em bypass de destinos, separados com ";" (ponto e vírgula).
    Com os hosts e ips do link acima que te passei, eu inseri nos Alias que eu já tinha, acrescentando os que estavam faltando, e depois disso foi que realmente surtiu o efeito e resolveu o problema.
    Inicialmente, tinha usado os hosts e ips sugeridos neste post, pelo usuário acamoura:
    https://forum.netgate.com/topic/144337/whats-app-lento-no-e2guardian/9

    E, se for necessário, liberar as portas do WhatsApp no firewall.

    Espero ter ajudado. Mais uma vez, peço desculpa pela demora... sei como é quando precisamos resolver esses rolos... hehe.
    Abraço



  • @regisek Tranquilo. Obrigado pela ajuda e retorno. Criei a regra apenas com os que tem no site ali do facebook. para depurar problemas. até agora tudo certo Obrigado camarada.



  • @diogenescorrea Legal! Pra mim também resolveu esse lance com estes endereços do link.
    Valeu, abraço!



  • This post is deleted!


  • This post is deleted!


  • @raffaD11 também me deparei com esse problema ao tentar instalar o e2g no ambiente de produção. A versão do meu Pfsense é a 2.4.4-RELEASE-p2 (amd64). Conseguiu encontrar alguma solução para esse problema? Na versão de homologação 2.4.4 RELEASE-p3 (amd64) instalou sem problemas.



  • @gersonalves Até agora sem novidades. Unica solução foi instalando em uma versão posterior do Pfsense...



  • This post is deleted!


  • Pessoal, estava lendo sobre o E2Guardian e me surgiu uma dúvida.
    Conseguimos criar um proxy transparente nele que consiga integrar com o AD, e que as máquinas que estejam no domínio loguem "automático"? Para quem já estiver no domínio não precisar logar nele? Ou que faça um captive portal, só que não peça pra quem já esta no domínio?



  • @andrebotelhof ,

    Nativo no E2guardian não, mas se pesquisar por autenticação transparente no pfsense você acha! ;-)

    Abraços!
    Jack



  • @JackL Oi Jack,

    Bah cara, obrigado pela resposta, já me ajudou muito.
    Eu dei uma pesquisada já, cheguei no pacote do Guga (pf2ad), tu acha que é por ai? Eu consegui fazer ele funcionar com proxy autenticado + NTLM, mas de modo transparente ainda não :/ Tem alguma dica?

    Abraços!



  • @andrebotelhof

    O pf2ad é um pacote (conjunto de scripts na prática) que implementa NTLM com Squid e até pode ser usado para configurar proxy autenticado transparentemente (com server AD) por exemplo. Mas ele não 'conversa' com E2Guardian.



  • This post is deleted!


  • Boa tarde Pessoal tudo joia?

    gostaria de uma informação. tenho aqui na empresa, um acesso remoto direto pelo SQL, onde na minha placa de rede local do servidor, esta um dos meus Ip´s da internet, sei que nao é uma pratica correta, mas tive que cerder a ordem de superiores, porem por minha sorte (ou nao) tive varias tentativas de acesso ao meu SQL neste final de semana.

    bem, o que gostaria de fazer, seria colocar um Pfsense no meu ip publico, criar uma regra que:- o Ip da empresa tercerira acessar meu pfsense pela wan, e redirecionado ao ip que esta configurado no meu servidor HP proliant. ja tentei algumas regras aqui mas sem sucesso.

    estou montando um cenario assim:- ex:-

    WAN da empresa terceria:- xxx.xxx.xxx.xxx

    placa rede 3 do servidor :- 192.168.1.0/24
    placa rede re0 Pfsense Lan 192.168.1.0/24

    placa bge0 Pfsense Wan xxx.xxx.xxx.xxx.

    qual regra que eu teria que fazer?

    action pass
    interface wan
    address ipv4
    protocol any

    SOURCE
    network (ip da empresa terceira) ou criar um alias com ip da empresa terceira

    DESTINATION
    network ip da placa de rede do servidor ?

    me desculpem, porem ainda nao tenho muita afinidade com firewall.

    obrigado a todos pela atençao,



  • @andrebotelhof, Se colocar um firewall na frente, o que você vai precisar fazer é um nat(firewall -> nat) a regra de firewall é criada automaticamente.



  • beleza... obrigado pela resposta @marcelloc e @JackL, vocês me ajudaram muito (:
    eu ainda estou fazendo alguns testes, assim que fica 100% eu aviso aqui.

    só por comentar, eu não havia trabalho ainda com o pfsense, e basicamente estou tentando usá-lo, junto com o squid (ou e2guardian), para gerenciar um ambiente com múltiplas redes. por exemplo: rede p funcionários (via radius + ad), rede cabeada (windows no ad, usando ntlm) e uma rede para visitantes utilizando captive portal. ainda não sei se essa é a melhor estratégia, mas parece que irá atender bem.

    novamente, obrigado pela ajuda ((:



  • @marcelloc
    i have install e2g with mitm and ad authantication with squid but when we enable transparent mode on e2g its occurs Proxy authentication error



  • @marcelloc
    Boa tarde Marcello!
    Tudo bem?
    Cara, primeiramente quero lhe parabenizar pelo excelente trabalho que você tem feito, acompanhei um vídeo seu, onde você orienta a instalação do E2guardian no pf2.4.4, e deu tudo certo!
    Agora terminei de configurar o Sarg e então estou precisando tirar uma dúvida com você. Como faço para melhorar o visual dos relatórios dele e também exportá-los em PDF.
    Vi que tem um pacote da Conexti, sarg-ng, que possibilita isso, mas este pacote é exclusivo para clientes deles, que pagaram a anuidade do serviço UserAuth.
    Aguardo as suas sempre bem-vindas orientações.
    Abraço.



  • @raffaD11 depois de muito tempo procurando, o problema esta no arquivo de configuração do pfSense.
    por incrível que pareça esta faltando isso. no meu caso estava faltando o <schedule></schedule>.

    Deixei assim e foi.
    <schedules>
    <schedule>
    </schedule>
    </schedules>

    Adicionei e resolveu o problema.



  • Olá @marcelloc, tudo bem?
    Na última sexta-feira, o E2Guardian estava funcionando perfeitamente as 23h, como pude verificar no arquivo log.

    A partir de 28/9, meia-noite, os arquivos access.log foram criados, porém tamanho zerado.

    Hoje, quando cheguei no meu trabalho, observei que o widget do E2Guardian estava sem os registros nos contadores e então fui verificar o Real Time, onde observei que não haviam acessos em tempo real sendo monitorados.

    Desativei o e2guardian, o ativei, reiniciei o serviço, reiniciei o pfSense e nada feito.

    Por fim, desinstalei e reinstalei o pacote dele e agora verifiquei que não voltou a funcionar.

    Por favor, poderia me ajudar?



  • @MRamon tenho o mesmo problema. vc conseguiu resolver?



  • Pessoal, ontem refiz a instalação do pfSense 2 vezes, restaurando as configurações do backup xml, que havia feito no dia 27/09, enquanto o E2Guardian ainda estava funcionando perfeitamente, porém, o erro que relatei acima persistiu.
    Por favor, alguém conseguiu resolver o problema?



  • vamos para a console, veja qual a saída de erro do e2guardian

    Mate os processos atuais e execute o e2guardian

    killall e2guardian
    
    e2guardian -Q
    


  • @marcelloc acabei restaurando o pfsense pra um backup onde tudo estava ok e então voltou a funcionar. Mas agora estou tendo problemas pra liberar o whatsapp. Se puder me ajudar agradeço desde já Marcello.



  • @rangel-glauco , estava com o mesmo problema

    tenho alguns instalados e pelo que pude perceber o problema é com a versão 0.5.3.3, pois com a versão 5.3.2_1 esta rodando tudo ok
    @marcelloc teria como voltar essa versão antiga ? ,ou qual o link que conseguimos trabalhar com ela ?



  • @marcelloc preciso de ajuda com o CP do UserAuth. Preciso personaliza-lo por completo. Vi que mudar cores e imagens é possível mas preciso inserir alguns links mudar nome do botão submit alem de retirar opção de baixar certificado e o nome da conexti. Como faço isso ?



  • @Rodrigo-Balan
    Bom dia, tenta assim:
    teste sql.PNG
    interface wan
    descrição o que vc desejar



  • Boa Tarde.. alguém tem uma black list de sites que burla proxy ?



  • Estou enfrentando um problema, ve se podem me ajudar...

    Os usuários não estão conseguindo baixar arquivos grandes, o download é cancelado quando chega no máximo a 45mb....

    Tentei baixar de várias fontes diferente. Testei de minha máquina pelo Firefox, passando pelo proxy e pelo chrome, sem proxy... Firefox interrompeu o download e no chrome não....

    Testei baixando a ISO do CentOS.

    Alguém sabe o que pode ser?

    ############### RESOLVIDO ################

    Nas configurações dos grupos, em LDAP, desmarquei as opções que estão marcadas na img abaixo. LDAP e LDAP user account status e o Update frequency deixei em branco

    e8243f2a-38e3-4e9d-94a7-b0db7b0c2b19-image.png



  • @marcelloc Meu querido funciona na versao 2.4.4-RELEASE-p3?



  • Boa tarde!

    Quero fazer um backup das configurações do E2G, qual arquivo eu backpeio, ou diretorio?



  • c29c7fb6-2410-4e50-9fe8-cf01360c674c-image.png

    Alguém sabe onde eu acho a explicação de cada coluna dessa, ou alguém pode explicar? Acredito que deve ser duvida de muitos.



  • Bom dia @marcelloc, tudo bem?
    Por favor, preciso esclarecer umas dúvidas com você.

    Tenho percebido no relatório de Real Time do E2Guardian, o acesso constante de uma máquina da minha rede ao ip do localhost, conforme print abaixo: pfSense - e2guardian realtime msg localhost.png

    Isso é normal?

    A última dúvida, embora não seja pertinente a este tópico, são alguns erros do NGINX, conforme log abaixo. Que por curiosidade pesquisei os hosts e verifiquei que são da Avast e do serviço de downloads Mega.co.nz. O que se refere estas falhas?

    Dec 3 14:01:29
    apati-fw.arcoiris.local

    nginx: 2019/12/03 14:01:29 [error] 66959#100135: *12722564 open() "/usr/local/www/v3/report" failed (2: No such file or directory), client: 127.0.0.1, server: , request: "POST /v3/report HTTP/1.1", host: "183.232.25.151"
    Dec 3 12:25:11
    apati-fw.arcoiris.local

    nginx: 2019/12/03 12:25:11 [error] 66959#100135: *12633840 open() "/usr/local/www/upgrade/device/version/check" failed (2: No such file or directory), client: 127.0.0.1, server: , request: "POST /upgrade/device/version/check HTTP/1.1", host: "update.lechange.cn:443"
    Dec 3 12:19:53
    apati-fw.arcoiris.local

    nginx: 2019/12/03 12:19:53 [error] 66959#100135: *12628745 open() "/usr/local/www/V1/REG" failed (2: No such file or directory), client: 127.0.0.1, server: , request: "POST /V1/REG HTTP/1.1", host: "77.234.42.207"
    Dec 3 12:19:41
    apati-fw.arcoiris.local

    nginx: 2019/12/03 12:19:41 [error] 66959#100135: *12628546 open() "/usr/local/www/V1/REG" failed (2: No such file or directory), client: 127.0.0.1, server: , request: "POST /V1/REG HTTP/1.1", host: "77.234.42.207"
    Dec 3 10:50:15
    apati-fw.arcoiris.local

    nginx: 2019/12/03 10:50:15 [error] 66959#100135: *12545922 open() "/usr/local/www/V1/REG" failed (2: No such file or directory), client: 127.0.0.1, server: , request: "POST /V1/REG HTTP/1.1", host: "77.234.42.207"
    Dec 3 10:49:50
    apati-fw.arcoiris.local

    nginx: 2019/12/03 10:49:50 [error] 66959#100135: *12544917 open() "/usr/local/www/V1/REG" failed (2: No such file or directory), client: 127.0.0.1, server: , request: "POST /V1/REG HTTP/1.1", host: "77.234.42.207"

    nginx: 2019/12/04 01:29:50 [error] 66959#100135: *13352579 open() "/usr/local/www/pf" failed (2: No such file or directory), client: 127.0.0.1, server: , request: "POST /pf?h HTTP/1.1", host: "g.api.mega.co.nz"



  • @William-Martins bom dia, tudo bem?
    Eu precisei fazer e resolvi fazer o backup geral do pfSense, que gera um XML de todas as configurações, inclusive a do E2Guardian.
    O caminho é: DIAGNOSTICS -> BACKUP & RESTORE -> "DOWNLOAD CONFIGURATION AS XML".

    Se precisar restaurar as configurações em uma instalação limpa do pfSense, nesta mesma tela poderá executar a reinstalação dos pacotes, em "REINSTALL PACKAGES".

    Espero ter podido lhe ajudar.

    Sucesso e que a força esteja com você William!


Log in to reply