Win DHCP mit Multiplen VLANS Pfsense als DHCP Relay



  • Hallo zusammen,
    ich versuche aktuell mehrere VLAN's aufzubauen. Im groben:

    Vlan 1 Ip Bereich 192.168.1.XXX
    Vlan 11 Ip Bereich 192.168.11.XXX
    Vlan 12 Ip Bereich 192.168.12.XXX
    Vlan 13 Ip Bereich 192.168.13.XXX
    Vlan 14 Ip Bereich 192.168.14.XXX

    Die Adressverteilung soll via Win Server DHCP laufen.

    Wie folgt ist konfiguriert:

    Win Server          an Switch Port 1 -> (Port 1 auf VLAN 1)
    Client 1                an Switch Port 2 -> (Port 2 auf VLAN 13)
    Pfsense Firewall  an Switch Port 23 -> (Port 23 hat VLAN 1 und 13)

    Die Firewall hat in den VLAN's die folgende IP:
    VLAN 1 192.168.1.3
    VLAN 11 192.168.11.1
    VLAN 12 192.168.12.1
    VLAN 13 192.168.13.1
    VLAN 14 192.168.14.1

    Der Windows Server hat die IP 192.168.1.10
    Im DHCP Server sind die Bereiche (Scope's) alle definiert

    In der Firewall wurde das DHCP Relay und die Server adresse 192.168.1.10 eingetragen.

    Sämtliche Rules wurden so eingestellt das ip4&6 mit sämtlichen Protokollen frei ist.

    Stecke ich den Clienten um in VLAN 1 erhalte ich eine IP-Adresse, in den restlichen nicht.

    Ich hoffe mir kann jemand erklären was genau ich falsch mache oder wie ich an die ganze Sache rangehen kann um das Problem zu finden.

    Mit dem Clienten kann ich die Firewall mit der entsprechenden VLAN adresse immer anpingen. Der DHCP-Server kann auch die Firewall anpingen.



  • Sieht aus, als ob das DHCP Relay nicht funktionieren würde. Wenn du den Client auf VLAN1 anschließt, bekommt er die IP wohl direkt vom DHCP Server.
    Hast du in den Einstellungen auch alle VLAN-Interfaces ausgewählt, außer 1?

    Übrigens, ist VLAN1 auf deinem Switch auch zulässig? Viele Switche verwenden dieses als Standard-Netz und es kann daher nicht für einzelne Ports separiert werden.


  • LAYER 8 Moderator

    Zudem die Frage ob dein Windows Server überhaupt Anfragen von allem was nicht 192.168.1.x ist annimmt, weil das die Win Firewall per default blockt. Das zum Einen, zum Anderen mal untersuchen, ob die DHCP Requests / Layer 2 überhaupt auf dem Interface ankommen.



  • Vielen dank für eure Hilfe.

    Folgendes war das Problem:
    Der DHCP Server hat den Request bekommen, allerdings konnte er ohne Standardgateway nicht auf die Anfrage antworten.
    Nachdem ich die Firewall als Standardgateway hinzugefügt habe lief alles ohne Probleme. Anschließend habe ich ihn einfach per Route auf das Gateway gezogen. Alles tuti nun :)

    Falls jemand den Thread findet und ein ähnliches Problem hat:

    Das Problem habe ich gefunden in dem ich mit hilfe von Wireshark, mir den Traffic auf dem Server angeschaut habe. Dort war zu sehen, dass die DHCP Anfrage eintrifft aber nicht raus kommt.


Log in to reply