Squidguard google safe search



  • In Squidguard Common ACL tab i've blocked specific categories and enabled safesearch, and in the Group ACL i've added a few ips and allowed all categories and didn't enable safesearch. While the categories are unblocked for those ips in the Group ACL safesearch still seems to be enabled, and I can't disable it unless i remove it from the Common ACL.





  • @aGeekHere:

    https://forum.pfsense.org/index.php?topic=112335.0

    Thanks for your response but it wasn't helpful in my case.

    What I did was disabled safe search and allowed all websites on the commons tab, and in the groups tab the top the first rule was to allow specific ip addresses to have access to everything and without enabling safe search; the second group, instead of writing individual ip's i just wrote down the subnet 192.168.1.0/24  enabled safe search and blocked a few categories. Since rules are applied in order this did exactly what i wanted.



  • Read the part about forcing google and bing into safe mode, as safesearch in squidguard does not work anymore



  • It does work with MITM and certificates installed on the computers and mobile devices. I originally had the dns settings for safe search but i've removed them and now I'm using squidguard safe search, which is working fine. So basically no need to force safe search using the DNS method if you have SSL certificate installed on all devices you can just us the squidguard safesearch.

    I've just double checked with enabling and disabling safesearch and it worked the way it's suppose to.