[solved] Strange Error after deleting GIF HE.net IPv6 tunnel latest RC



  • Hi,

    I often see following log entries that I didn't see before removing HE.net tunnel in latest RC build.
    78.46.223.24 is nordvpn dns server i entered in system -> general setup
    The errors were similar to 78.46.223.24 but with quad9 ipv6 dns servers earlier but then I removed ipv6 dns servers from system -> general setup and then I started seeing following errors.

    Mar 25 22:47:34	php-fpm	326	/system.php: The command '/sbin/route delete -host ' returned exit code '64', the output was 'route: destination parameter required route: usage: route [-46dnqtv] command [[modifiers] args]'
    ... editing dns under System -> General Setup
    Mar 25 22:46:28	php-fpm	52075	/services_unbound.php: The command '/sbin/route delete -host ' returned exit code '64', the output was 'route: destination parameter required route: usage: route [-46dnqtv] command [[modifiers] args]'
    ... changed unbound settings
    Mar 25 22:40:42	php-fpm	326	/rc.newwanip: The command '/sbin/route delete -host ' returned exit code '64', the output was 'route: destination parameter required route: usage: route [-46dnqtv] command [[modifiers] args]'
    ... openvpn interface up
    Mar 25 22:40:34	php-fpm	325	/rc.newwanip: The command '/sbin/route delete -host ' returned exit code '64', the output was 'route: destination parameter required route: usage: route [-46dnqtv] command [[modifiers] args]'
    Mar 25 22:40:34	php-fpm	325	/rc.newwanip: The command '/sbin/route delete -host ' returned exit code '64', the output was 'route: destination parameter required route: usage: route [-46dnqtv] command [[modifiers] args]'
    Mar 25 22:40:34	php-fpm	325	/rc.newwanip: The command '/sbin/route delete -host 78.46.223.24' returned exit code '1', the output was 'route: route has not been found delete host 78.46.223.24 fib 0: not in table'
    ... wan interface up
    Mar 25 22:40:33	php-cgi		rc.bootup: The command '/sbin/route delete -host ' returned exit code '64', the output was 'route: destination parameter required route: usage: route [-46dnqtv] command [[modifiers] args]'
    Mar 25 22:40:33	php-cgi		rc.bootup: The command '/sbin/route delete -host ' returned exit code '64', the output was 'route: destination parameter required route: usage: route [-46dnqtv] command [[modifiers] args]'
    Mar 25 22:40:33	php-cgi		rc.bootup: The command '/sbin/route delete -host 78.46.223.24' returned exit code '1', the output was 'route: route has not been found delete host 78.46.223.24 fib 0: not in table'
    
    


  • I created a ticket: https://redmine.pfsense.org/issues/8390

    I partially fixed the issue by adding dns 2620:fe::fe and then deleting it.

    Now I only see one error message at bootup (and no error at openvpn up/changing unbound settings/changing dns):

    
    Mar 25 23:24:40	php-fpm	326	/rc.newwanip: The command '/sbin/route delete -host ' returned exit code '64', the output was 'route: destination parameter required route: usage: route [-46dnqtv] command [[modifiers] args]'
    Mar 25 23:24:40	php-fpm	326	/rc.newwanip: The command '/sbin/route delete -host 78.46.223.24' returned exit code '1', the output was 'route: route has not been found delete host 78.46.223.24 fib 0: not in table'
    ... wan up
    Mar 25 23:24:39	php-cgi		rc.bootup: The command '/sbin/route delete -host ' returned exit code '64', the output was 'route: destination parameter required route: usage: route [-46dnqtv] command [[modifiers] args]'
    Mar 25 23:24:39	php-cgi		rc.bootup: The command '/sbin/route delete -host 78.46.223.24' returned exit code '1', the output was 'route: route has not been found delete host 78.46.223.24 fib 0: not in table'
    
    


  • Just did fresh install and restored config, still see errors.



  • my config.xml file had <dns5gw>NORDVPN_DHCP</dns5gw>
    despite having no DNS entries in System/Advanced

    changed it to <dns5gw>none</dns5gw> and problem solved!

    I would like to thank the source code for helping me narrow down the problem.


Log in to reply