ACME Error: Parse error reading JWS



  • I'm getting "[Fri Mar 23 02:39:40 UTC 2018] Create new order error. Le_OrderFinalize not found. {"type":"urn:ietf:params:acme:error:malformed","detail":"Parse error reading JWS","status": 400}" when trying to issue the certificate.

    It seems it was related to https://github.com/Neilpang/acme.sh/issues/1360 , but when running acme.sh manually from the console it works. Maybe someone knows what the problem could be?

    I've tried deleting the file mentioned and upgraded the acme to the developer version but still doesn't fix the problem.

    /cbadk


  • Rebel Alliance Developer Netgate

    Can you try again with version 0.2.6 of the ACME package? If there is no improvement, please post more of your acme_issuecert.log and some information about your setup, such as what type of validation method you are using.



  • Thanks for the feedback.

    Did you push the update yet? Can't see it….


  • Rebel Alliance Developer Netgate

    If you are on 2.4.2-p1 or 2.3.5 you should see it already.

    If you are on 2.4.3-RC or another snapshot, 2.4.4, or 2.3.6, it won't show up until the next snapshot run is complete and public. In the case of 2.4.3, that will probably not happen until it hits -RELEASE once our testing is complete.



  • Oh yeah, that might be the reason. Using version 2.4.4. Will try when the next snapshot gets pushed.
    I've noticed that he put a  "–yes-I-know-dns-manual-mode-enough-go-ahead-please" in the code now. Really a funny slash weird move if you ask me. But maybe it was causing confusion idk.

    $cmdparameters .= " --yes-I-know-dns-manual-mode-enough-go-ahead-please "; <--- that one might fix it for now until i get the nsupdate fixed for my DNS servers.

    Getting nsupdate working on webmin panel can be a painful process. Haven't been successful yet.


  • Rebel Alliance Developer Netgate

    I saw that, and 0.2.6 adds adds that to the cmd parameters already



  • Aw, still no new snapshot build yet for 2.4.4. Hope one will show up soon together with the ACME package update ;)


  • Rebel Alliance Developer Netgate

    The snaps will start back up after 2.4.3-RELEASE is put up which should be real soon now.



  • Just got the new build this morning. We are back in business. It works. Just have to test the nsupdate now.  Thanks 8)