PFsense & Hamachi (VPN) Relayed problem



  • Hi all

    I just installed PFsense and all is working ok for normal firewall operation and NAT

    I also use Hamachi on a PC for sort of VPN

    I notice that since the installation of pfsense the status of hamachi behind PFsense is now "blue arrow" saying "relayed" on the hamachi
    web support site

    anyone who can help me

    I tried to setup TCP and UDP port 65000 and made a NAT but no succes

    anyone using hamachi behind a PFsense ?

    Thanks



  • Have you tried to enable static ports?
    http://doc.pfsense.org/index.php/Static_Port



  • @GruensFroeschli:

    Have you tried to enable static ports?
    http://doc.pfsense.org/index.php/Static_Port

    Thanks

    I'm using pfsense 1.2 RC2 embedded so i dont see Firewall -> NAT, and the Outbound tab. Click "Manual Outbound NAT rule generation (Advanced Outbound NAT (AON))"

    Is this available in the embedded version ?



  • Look again.
    It's there in all versions.



  • @GruensFroeschli:

    Look again.
    It's there in all versions.

    Oeps I found the tap =)

    I configured Hamachi to use UDP& TCP port 65000 on both PC's (one behind PFsense the other on the internet by another ISP)
    in PFsense I made a nat for UDP&TCP port 65000 to the IP of the PC running hamachi behind PFsense
    then in Firewall -> NAT, and the Outbound tab. Click "Manual Outbound NAT rule generation (Advanced Outbound NAT (AON))" and click Save
    but still the blue arrow status saying relayed

    :(



  • Click "Manual Outbound NAT rule generation (Advanced Outbound NAT (AON))" and click Save. You will then see a rule at the bottom of the page labeled "Auto created rule for LAN". Click the "e" button to the right of that rule to edit it. Check the "static port" box on that page, and click Save. Apply changes and this behavior will be disabled.



  • @GruensFroeschli:

    Click "Manual Outbound NAT rule generation (Advanced Outbound NAT (AON))" and click Save. **You will then see a rule at the bottom of the page labeled "Auto created rule for LAN". Click the "e" button to the right of that rule to edit it. Check the "static port" box on that page, and click Save. Apply changes and this behavior will be disabled.

    Hi again,

    And thanks for the quick reply
    This is what I did, I enclose a screen grab from NAT and Firewall Rule
    also the hamachi preferences

    ![pfsense 1.JPG](/public/imported_attachments/1/pfsense 1.JPG)
    ![pfsense 1.JPG_thumb](/public/imported_attachments/1/pfsense 1.JPG_thumb)
    ![pfsense 2.JPG](/public/imported_attachments/1/pfsense 2.JPG)
    ![pfsense 2.JPG_thumb](/public/imported_attachments/1/pfsense 2.JPG_thumb)**



  • Ok you didnt write that you enabled static port (only that you enabled AoN) ;)

    In your portforward rule you have as source 65000.
    This will never happen because the source is always a random port. –> The rule will never be applied.
    Set the source to "any" and it should work.



  • @GruensFroeschli:

    Ok you didnt write that you enabled static port (only that you enabled AoN) ;)

    In your portforward rule you have as source 65000.
    This will never happen because the source is always a random port. –> The rule will never be applied.
    Set the source to "any" and it should work.

    Thanks

    I did the modification but no result  ???  :'( (I did apply changes)

    But then i took the reboot option and restarted PFsense, and all ok !!!

    Strange I had this before with an other configuration

    Many thanks !!!

    I think we can say Topic closed !


Locked