PFSENSE booting problem – please help



  • I succesfully installed pfsense 1.2.2. But after installation it's not coming up, got stuck up after pressing F1.

    F1 pfSense
    Default: F1

    \

    Thanks in advance..



  • I have a suspicion that the FreeBSD boot loader needs the controller for the boot ATA drive to be at the "legacy" IO addresses. This generally happens naturally when the system supports parallel ATA drives but not serial ATA drives. When there is support for both S-ATA and P-ATA drives then some BIOS tweaks around the ATA (or IDE) configuration may be required.

    Does your motherboard support S-ATA and P-ATA drives?
    Did you install from CD?
    If so, what type of CD? (e.g P-ATA, S-ATA, USB)
    Is the hard drive S-ATA or P-ATA or something else?



  • I installed pfsense from CD.

    I am using S-ATA HDD and CD drive. In BIOS there are options to configure SATA as IDE or RAID. Now it's configured with IDE.

    Thanks
    Aklspec



  • There are quite a few different hard drive controller configurations available now. I don't know the specifics for your motherboard.

    I think what you need is the boot drive to be on a disk controller in "legacy" IDE mode which should mean its at i/o ports 0x1f0-0x1f7, 0x3f6, 0x170-0x177, 0x376.

    Probably the most effective way to check this is to boot the CD for "live CD" mode (run off the CD, don't install), configure the interfaces, connect to it via the web GUI, on the Diagnostics menu click on command, type dmesg in the box under "Execute Shell command" then click the execute box, capture the resulting output and post it in a reply and I'll take a look.

    The dmesg output should include something like

    atapci0: <via 8235="" udma133="" controller="">port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xea00-0xea0f at device 17.1 on pci0
    ata0: <ata 0="" channel="">on atapci0
    ata0: [ITHREAD]
    ata1: <ata 1="" channel="">on atapci0
    ata1: [ITHREAD]</ata></ata></via>

    (though the number after atapci might be different) which is an IDE controller at the "legacy" i/o addresses and it should be followed, possibly quite a few lines down, by something like

    ad0: 955MB <transcend 20071207="">at ata0-master UDMA33</transcend>

    which reports a ATA/IDE disk of 955MB, the next item is the drive identification string and the next item shows the drive is accessed through ata0 which (in this case) is one of the two ata controllers at the legacy i/o addresses.



  • I actually have the exact same issue.  Here is the output of dmesg.  Hopefully this is enough info to fix the issue.

    dmesg
    Copyright © 1992-2008 The FreeBSD Project.
    Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
    The Regents of the University of California. All rights reserved.
    FreeBSD is a registered trademark of The FreeBSD Foundation.
    FreeBSD 7.0-RELEASE-p8 #0: Thu Jan  8 22:29:30 EST 2009
        sullrich@freebsd7-releng_1_2_1.pfsense.org:/usr/obj.pfSense/usr/src/sys/pfSense_SMP.7
    Timecounter "i8254" frequency 1193182 Hz quality 0
    CPU: AMD Sempron(tm) Processor 3000+ (1800.08-MHz 686-class CPU)
      Origin = "AuthenticAMD"  Id = 0x20fc2  Stepping = 2
      Features=0x78bfbff <fpu,vme,de,pse,tsc,msr,pae,mce,cx8,apic,sep,mtrr,pge,mca,cmov,pat,pse36,clflush,mmx,fxsr,sse,sse2>Features2=0x1 <sse3>AMD Features=0xe2500800 <syscall,nx,mmx+,ffxsr,lm,3dnow!+,3dnow!>AMD Features2=0x1 <lahf>real memory  = 1609760768 (1535 MB)
    avail memory = 1563537408 (1491 MB)
    ACPI APIC Table: <a m="" i ="" oemapic="">ioapic0: Changing APIC ID to 1
    MADT: Forcing active-low polarity and level trigger for SCI
    ioapic0 <version 0.3="">irqs 0-23 on motherboard
    wlan: mac acl policy registered
    kbd1 at kbdmux0
    ath_hal: 0.9.20.3 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
    hptrr: HPT RocketRAID controller driver v1.1 (Jan  8 2009 22:29:11)
    cryptosoft0: <software crypto="">on motherboard
    acpi0:</software></version></a> <a m="" i="" oemrsdt="">on motherboard
    acpi0: [ITHREAD]
    acpi0: Power Button (fixed)
    acpi0: reservation of 0, a0000 (3) failed
    acpi0: reservation of 100000, 5fef0000 (3) failed
    Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
    acpi_timer0: <24-bit timer at 3.579545MHz> port 0x808-0x80b on acpi0
    cpu0: <acpi cpu="">on acpi0
    powernow0: <cooln'quiet k8="">on cpu0 pcib0: <acpi host-pci="" bridge="">port 0xcf8-0xcff on acpi0 pci0: <acpi pci="" bus="">on pcib0 agp0: <via 8380="" host="" to="" pci="" bridge="">on hostb0 pcib1: <acpi pci-pci="" bridge="">at device 1.0 on pci0 pci1: <acpi pci="" bus="">on pcib1 vgapci0: <vga-compatible display="">mem 0xfb000000-0xfbffffff,0xe0000000-0xefffffff,0xfa000000-0xfaffffff irq 16 at device 0.0 on pci1 fwohci0: <via fire="" ii="" (vt6306)="">port 0xe800-0xe87f mem 0xf9e00000-0xf9e007ff irq 16 at device 7.0 on pci0 fwohci0: [FILTER] fwohci0: OHCI version 1.0 (ROM=1) fwohci0: No. of Isochronous channels is 4. fwohci0: EUI64 00:11:d8:00:00:81:11:63 fwohci0: Phy 1394a available S400, 2 ports. fwohci0: Link S100, max_rec 2 bytes. fwohci0: max_rec 2 -> 2048 firewire0: <ieee1394(firewire) bus="">on fwohci0 fwe0: <ethernet over="" firewire="">on firewire0 if_fwe0: Fake Ethernet address: 02:11:d8:81:11:63 fwe0: Ethernet address: 02:11:d8:81:11:63 fwip0: <ip over="" firewire="">on firewire0 fwip0: Firewire address: 00:11:d8:00:00:81:11:63 @ 0xfffe00000000, S400, maxrec 2048 sbp0: <sbp-2 scsi="" over="" firewire="">on firewire0 dcons_crom0: <dcons configuration="" rom="">on firewire0 dcons_crom0: bus_addr 0x13a4000 fwohci0: Initiate bus reset fwohci0: BUS reset fwohci0: node_id=0xc800ffc0, gen=1, CYCLEMASTER mode rl0: <d-link 10="" dfe-530tx+="" 100basetx="">port 0xe400-0xe4ff mem 0xf9d00000-0xf9d000ff irq 16 at device 11.0 on pci0 miibus0: <mii bus="">on rl0 rlphy0: <realtek internal="" media="" interface="">PHY 0 on miibus0 rlphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto rl0: Ethernet address: 00:0d:88:31:46:56 rl0: [ITHREAD] pcn0: <amd 10="" pcnet="" pci="" 100basetx="">port 0xe000-0xe01f mem 0xf9c00000-0xf9c0001f irq 18 at device 13.0 on pci0 pcn0: Chip ID 2623 (Am79C971) miibus1: <mii bus="">on pcn0 lxtphy0: <lxt970 10="" 100="" media="" interface="">PHY 1 on miibus1 lxtphy0:  100baseFX, 100baseFX-FDX, 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto ukphy0: <generic ieee="" 802.3u="" media="" interface="">PHY 31 on miibus1 ukphy0:  10baseT, 10baseT-FDX, auto pcn0: using obsoleted if_watchdog interface pcn0: Ethernet address: 00:00:e8:89:ec:ed pcn0: [ITHREAD] atapci0: <via 6420="" sata150="" controller="">port 0xd800-0xd807,0xd400-0xd403,0xd000-0xd007,0xc800-0xc803,0xc400-0xc40f,0xc000-0xc0ff irq 20 at device 15.0 on pci0 atapci0: [ITHREAD] ata2: <ata 0="" channel="">on atapci0 ata2: [ITHREAD] ata3: <ata 1="" channel="">on atapci0 ata3: [ITHREAD] atapci1: <via 8237="" udma133="" controller="">port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xfc00-0xfc0f at device 15.1 on pci0 ata0: <ata 0="" channel="">on atapci1 ata0: [ITHREAD] ata1: <ata 1="" channel="">on atapci1 ata1: [ITHREAD] uhci0: <via 83c572="" usb="" controller="">port 0xa800-0xa81f irq 21 at device 16.0 on pci0 uhci0: [GIANT-LOCKED] uhci0: [ITHREAD] usb0: <via 83c572="" usb="" controller="">on uhci0 usb0: USB revision 1.0 uhub0: <via 1="" 9="" uhci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usb0 uhub0: 2 ports with 2 removable, self powered uhci1: <via 83c572="" usb="" controller="">port 0xb000-0xb01f irq 21 at device 16.1 on pci0 uhci1: [GIANT-LOCKED] uhci1: [ITHREAD] usb1: <via 83c572="" usb="" controller="">on uhci1 usb1: USB revision 1.0 uhub1: <via 1="" 9="" uhci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usb1 uhub1: 2 ports with 2 removable, self powered uhci2: <via 83c572="" usb="" controller="">port 0xb400-0xb41f irq 21 at device 16.2 on pci0 uhci2: [GIANT-LOCKED] uhci2: [ITHREAD] usb2: <via 83c572="" usb="" controller="">on uhci2 usb2: USB revision 1.0 uhub2: <via 1="" 9="" uhci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usb2 uhub2: 2 ports with 2 removable, self powered uhci3: <via 83c572="" usb="" controller="">port 0xb800-0xb81f irq 21 at device 16.3 on pci0 uhci3: [GIANT-LOCKED] uhci3: [ITHREAD] usb3: <via 83c572="" usb="" controller="">on uhci3 usb3: USB revision 1.0 uhub3: <via 1="" 9="" uhci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usb3 uhub3: 2 ports with 2 removable, self powered ehci0: <via vt6202="" usb="" 2.0="" controller="">mem 0xf9900000-0xf99000ff irq 21 at device 16.4 on pci0 ehci0: [GIANT-LOCKED] ehci0: [ITHREAD] usb4: EHCI version 1.0 usb4: companion controllers, 2 ports each: usb0 usb1 usb2 usb3 usb4: <via vt6202="" usb="" 2.0="" controller="">on ehci0 usb4: USB revision 2.0 uhub4: <via 1="" 9="" ehci="" root="" hub,="" class="" 0,="" rev="" 2.00="" 1.00,="" addr="">on usb4 uhub4: 8 ports with 8 removable, self powered isab0: <pci-isa bridge="">at device 17.0 on pci0 isa0: <isa bus="">on isab0 pci0: <multimedia, audio="">at device 17.5 (no driver attached) vr0: <via 10="" vt6102="" rhine="" ii="" 100basetx="">port 0xa000-0xa0ff mem 0xf9800000-0xf98000ff irq 23 at device 18.0 on pci0 vr0: Quirks: 0x0 vr0: Revision: 0x78 miibus2: <mii bus="">on vr0 ukphy1: <generic ieee="" 802.3u="" media="" interface="">PHY 1 on miibus2 ukphy1:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto vr0: Ethernet address: 00:15:f2:63:39:0b vr0: [ITHREAD] acpi_button0: <power button="">on acpi0 atkbdc0: <keyboard controller="" (i8042)="">port 0x60,0x64 irq 1 on acpi0 atkbd0: <at keyboard="">irq 1 on atkbdc0 kbd0 at atkbd0 atkbd0: [GIANT-LOCKED] atkbd0: [ITHREAD] speaker0: <pc speaker="">port 0x61 on acpi0 fdc0: <floppy drive="" controller="" (fde)="">port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on acpi0 fdc0: [FILTER] sio0: configured irq 4 not in bitmap of probed irqs 0 sio0: port may not be enabled sio0: configured irq 4 not in bitmap of probed irqs 0 sio0: port may not be enabled sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0 sio0: type 16550A sio0: [FILTER] sio1: <16550A-compatible COM port> port 0x2f8-0x2ff irq 3 on acpi0 sio1: type 16550A sio1: [FILTER] pmtimer0 on isa0 orm0: <isa option="" rom="">at iomem 0xcf000-0xd0fff pnpid ORM0000 on isa0 ppc0: <parallel port="">at port 0x378-0x37f irq 7 on isa0 ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode ppc0: FIFO with 16/16/9 bytes threshold ppbus0: <parallel port="" bus="">on ppc0 ppbus0: [ITHREAD] plip0: <plip network="" interface="">on ppbus0 lpt0: <printer>on ppbus0 lpt0: Interrupt-driven port ppi0: <parallel i="" o="">on ppbus0 ppc0: [GIANT-LOCKED] ppc0: [ITHREAD] sc0: <system console="">at flags 0x100 on isa0 sc0: VGA <16 virtual consoles, flags=0x300> vga0: <generic isa="" vga="">at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0 Timecounter "TSC" frequency 1800076715 Hz quality 800 Timecounters tick every 1.000 msec Fast IPsec: Initialized Security Association Processing. hptrr: firewire0: 1 nodes, maxhop <= 0, cable IRM = 0 (me) firewire0: bus manager 0 (me) no controller detected. ad0: 76319MB <wdc wd800jb-00jjc0="" 05.01c05="">at ata0-master PIO4 acd0: DVDR <benq dvd="" dd="" dw1650="" bcdc="">at ata1-slave PIO4 GEOM_LABEL: Label for provider acd0 is iso9660/pfSense. Trying to mount root from cd9660:/dev/iso9660/pfSense md0.uzip: 1049 x 65536 blocks pflog0: promiscuous mode enabled</benq></wdc></generic></system></parallel></printer></plip></parallel></parallel></isa></floppy></pc></at></keyboard></power></generic></mii></via></multimedia,></isa></pci-isa></via></via></via></via></via></via></via></via></via></via></via></via></via></via></via></ata></ata></via></ata></ata></via></generic></lxt970></mii></amd></realtek></mii></d-link></dcons></sbp-2></ip></ethernet></ieee1394(firewire)></via></vga-compatible></acpi></acpi></via></acpi></acpi></cooln'quiet></acpi></a></lahf></syscall,nx,mmx+,ffxsr,lm,3dnow!+,3dnow!></sse3></fpu,vme,de,pse,tsc,msr,pae,mce,cx8,apic,sep,mtrr,pge,mca,cmov,pat,pse36,clflush,mmx,fxsr,sse,sse2>



  • I'm having similar problems.

    I tried to install again with GRUB - install of GRUB fails because it can't mount the filesystem.

    I also tried to install again with Packet mode off and GRUB on, same problem.

    Any suggestion would be appreciated.

    3vian



  • @3vian:

    I'm having similar problems.

    I tried to install again with GRUB - install of GRUB fails because it can't mount the filesystem.

    I don't know what you mean by "install with GRUB". Please clarify. I don't recall ever seeing GRUB involved in a pfSense install.

    When you say "can't mount the filesystem" do you mean you saw something like:

    Trying to mount root from ufs:/dev/ad0s1a

    Manual root filesystem specification:
      <fstype>:<device>  Mount <device>using filesystem <fstype>eg. ufs:da0s1a
      ?                  List valid disk boot devices
      <empty line="">      Abort manual input

    mountroot></empty></fstype></device></device></fstype>

    Whats happening at this point is that the bootloader has looked up /etc/fstab on the boot partition to see where the root file system is/should be, but the kernel has not found it there. Some people have reporting seeing this sort of thing when using a Seagate microdrive as the book drive. I've seen this sort of thing when I've installed on a drive, unplugged the drive from the motherboard for some reason then plugged the drive back into the motherboard in a different socket (thus changing the unit number); for example on an older motherboard with no S-ATA support, installed on ad0, the master drive in the primary IDE slot, then rebooted with drive as ad2, the master drive in the secondary IDE slot, /etc/fstab on boot partition on ad2 says the root file system is on ad0 but there is no ad0 drive. I've also seen this happen when playing around with the BIOS IDE configuration on motherboards that support a mix of parallel IDE and Serial ATA drives.

    theluketaylor: Thanks for the dmesg output. Looks to me that both your hard drive and DVD drive are on the ATA controller at the legacy I/O addresses so you quite likely have a different problem from that of the original poster, though it may well look the same. Your hard drive, ad0, is on ata0 which is on atapci1 which has legacy I/O addresses: 0x1f0-0x1f7 etc.



  • @3vian:

    I'm having similar problems.

    I tried to install again with GRUB - install of GRUB fails because it can't mount the filesystem.

    I also tried to install again with Packet mode off and GRUB on, same problem.

    Any suggestion would be appreciated.

    3vian

    I have that problem as well.  During the bootblock section of the install there is an option to use grub.  I selected that and then the install hangs trying to install grub.  It then gives the error can't mount the filesystem.  Looking at the grub output it happens on the line root(hd0,0,a).  It then says bootblocks installed successfully.  I have also tried installing with grub not selected (between which I cleared the MBR to ensure there was no cruft since I was using grub as a bootloader before)/

    wallabybob: if the issue isn't legacy I/O addresses what could be causing this issue?  When I hit F1 to boot I get a /, the hard drive activity light goes on for 10-15 seconds then nothing else happens.  It seems to be a boot issue since the install itself is able to read and write to the drive without any trouble.  Any ideas?



  • I tried installing freebsd 7 to see if this problem exists in the normal install and it worked fine.  This appears to be a problem with the pfsense installer and not freebsd itself



  • I was having different problems before I upgraded my bios.  I would installed w/o GRUB and it is wouldn't boot at all - I would get something about the there being No /boot/loader and then it would follow with error 1 lba #######, which was followed by No /boot/kernel/kernel/.  This is just from memory, so I can't be certain it's correct.

    So I tried installing with GRUB as an options - which failed during installation (couldn't moutn fs).  But it got further after reboot - I got the error wallabybob mentioned.  Then when I mounted the filesystem by typing ufs:da0s1a and it would boot.  I thought it would be adxsxa, so i suspect i was booting from the cd-rom.

    When you say "can't mount the filesystem" do you mean you saw something like:

    Trying to mount root from ufs:/dev/ad0s1a

    Manual root filesystem specification:
      <fstype>:<device>  Mount <device>using filesystem <fstype>eg. ufs:da0s1a
      ?                  List valid disk boot devices
      <empty line="">      Abort manual input

    mountroot></empty></fstype></device></device></fstype>

    Finally I gave up and upgraded the BIOS.  Now all installation options lead to the same place.  With or w/o GRUB and with or w/o Packet Mode.  They all just give this upon booting:

    \

    I noticed that my bios seems to assign the HDD and CD to random channels after every bootup - something the hdd will be on 0 and then the next time on 3.

    FYI - I'm using a Tyan tiger i7501R motherboard.  And I've now tried two different HDD.

    Could posting the IDE options from the bios help?  I've looked at other posts and suggestions and it is not clear to me that my bios allows for what they did, but perhaps newer eyes will see something I didn't.

    Lawrence

    PS.  Aklspec sorry for hijacking your thread…



  • yes I'm also sorry for the hijack.  I installed pfsense again without packet mode on the bootblocks and it got me further.  I get to the pfsense menu, the line /boot/kernel/acpi.kp text=0x520e8 data=0x23a0+0x186c syms=[0x485c0+0x4+0xb056] then there is just a \ and nothing



  • So that is w/o GRUB and w/o Packet Mode?  Perhaps I'll try that.



  • Tried w/o Packet Mode and w/o GRUB, now I'm back to the old problem - I get the following:

    F1    pfSense
    
    Default: F1
    
    error 1 lba 357911055
    No /boot/loader
    
    pfSense/i386 boot
    Default: 0:ad(0,a)/boot/kernel/kernel
    boot:
    error 1 lba 357911055
    No /boot/kernel/kernel
    
    pfSense/i386 boot
    Default: 0:ad(0,a)/boot/kernel/kernel
    boot:
    


  • Here are my BIOS options, Bold is the current setting.

    |
    IDE Legacy Configuration
    S-ATA Running Enhanced Mode
    P-ATA Channel Selection
    S-ATA Ports Definition
    Configure S-ATA as RAID
    Hard Disk Write Protect
    IDE Detect Time Out (Sec)
    ATA(PI) 80Pin Cable Detection
    |
    Disabled, P-ATA Only, S-ATA Only, P-ATA & S-ATA
    Yes, No
    Primary, Secondary, Both
    P0-3rd./P1-4th., P0-4th./P1-3rd.
    No, Yes
    Disabled, Enabled
    0, 5, 10, 15, 20, 25, 30, 35
    HOST & DEVICE, HOST, DEVICE
    |

    It then lists all the attached devices and under the HDD this is what I get.

    |
    Device
    Vendor
    Size
    LBA Mode
    Block Mode
    PIO Mode
    Async DMA
    Ultra DMA
    S.M.A.R.T.

    Type
    LBA/Large Mode
    Block (Multi-Sector Trans)
    PIO Mode
    DMA Mode
    S.M.A.R.T
    32Bit Data Transfer |
    :Hard Disk
    :Maxtor 6B200R0
    :203.9GB
    :Supported
    :16Sectors
    :4
    :MultiWord DMA-2
    :Ultra DMA-6
    :Supported

    Auto, CDROM, ARMD
    Disabled, Auto
    Disabled, Auto
    Auto, 0, 1, 2, 3, 4
    Auto, SWDMA0, SWDMA1, SWDMA2, MWDMA0, MWDMA1, MWDMA2, UDMA0, UDMA1, UDMA2, UDMA3, UDMA4, UDMA5, UDMA6
    Auto, Disabled, Enabled
    Disabled, Enabled |

    I also have the drive with CS jumper and it is a single connection ribbon.  If you have any suggestion on what might need to be changed in the BIOS let me know.



  • There are problem reports from three separate users here. My apologies if I confuse the details.

    On motherboards with S-ATA support, RAID and AHCI there are lots of possible combinations of BIOS settings related to the hard drives. And they can have different names depending on the BIOS. These settings can impact the way FreeBSD assigns unit numbers to ATA drives. For example, I've done some experiments on a ASUS P5LD2-SE motherboard and without changing any cabling but just changing BIOS IDE configuration settings I have had a S-ATA drive appear to FreeBSD as ad0, ad4 or ad8 (not sure about ad8!). The point is, if you play around with the BIOS IDE settings between installing ad attempting to boot you may have some trouble.

    FreeBSD seems to reserve ata-0 and ata-1 for disk controllers at legacy I/O addresses. If you configure your IDE so neither P-ATA nor S-ATA are in legacy mode then FreeBSD won't have ata-0 nor ata-1 and consequently won't have drives ad0, ad1, ad2 or ad3. I have no idea how this interacts with GRUB which will no doubt have its own way (possibly well documented) of assigning hard drive numbers. Lets leave GRUB out of this to remove an element of uncertainty.

    I earlier stated I thought FreeBSD boot needed to be from a controller at legacy i/o addresses. I was mistaken, my apologies. I have seen reports on the net of various boot issues with S-ATA controllers in RAID or AHCI mode so lets disable those modes. pfSense is not normally disk intensive so there is little to be gained by enabling a higher performance disk mode. On that ASUS motherboard I mentioned earlier I successfully booted FreeBSD 7.0 from ad4, a S-ATA drive with Enhanced IDE mode enabled on S-ATA. With S-ATA in legacy mode the same drive became ad0 and I successfully booted FreeBSD 7.0. This is the mode I have routinely used for FreeBSD on this motherboard, so when the S-ATA drives was ad4 the boot ran through all the usual startup reporting then said it failed to find the root file system. This is because /etc/fstab on ad4 said the root file system was on ad0 and there was no ad0 because I'd played with the BIOS IDE configuration. I was able to use the hint from the OS to get the root file system mounted then changed /etc/fstab to specify the new drive id for the file systems, rebooted and all was well.

    Suggestion: If you can, configure IDE in BIOS to have only P-ATA or S-ATA (depending on what drives you have), disable any unused disk controllers you can put the controller in legacy mode, reinstall and reboot.

    I've not had any problems with pfSense installs on a number of older systems without S-ATA controllers. I've never used GRUB with pfSense.

    I've recently put together a system with AMD 780G chipset for watching digital TV. I'll try a pfSense boot from CD and install on it to expand my experience. It may also contribute something to this topic.



  • I tried installing pfSense 1.2.2 on an ASUS M3A78-EMH HDMI motherboard, the only motherboard which supports SATA and is available to me for this sort of experiment. The CD installer wouldn't get past reporting ehci0 unless I disabled USB. Once I got pfSense booted from the CD it didn't recognise the onboard Realtek LAN so I had only one available interface (plip0) and I couldn't figure out a way to get past that to install to a hard drive.

    I then tried a 1.2.3 testing image. I burned it to CD then booted the CD and the onboard NIC was recognised. I rebooted and in the BIOS I enabled the USB interfaces and the boote completed. I was was enable to specify two VLANs on re0 as the interfaces and then I was able to install to ad8 (packet mode, not GRUB) and boot off ad8. ad8 was a S-ATA drive connected to a non-legacy S-ATA controller. In the BIOS I could set the Onchip SATA type to either SATA or AHCI and pfSense still booted from ad8.

    Maybe its worth trying a 1.2.3 snapshot.



  • Tried 1.2.3 and 2.0 - no help.  I guess I need to start fiddling with the BIOS and just see what happens.



  • Just installed trixbox without a problem.  I had windows on this box before, no problem.  I'm going to try to install freebsd and see what happens.  Just seems odd that there are all these problems with the install.  Okay, maybe not odd, but frustrating.  My ultimate goal is to replace my pfSense and trixbox machines with one 1U server running pfSense and FreeSWITCH…

    If I were to install pfS on another machine and then just take the drive out and put it in this machine would that have any chance of working?



  • If I were to install pfS on another machine and then just take the drive out and put it in this machine would that have any chance of working?

    I have successfully done this in the past. For least troublesome outcome, you should configure you drive on the "run" system to have the same unit number as on the "install" system, though if that doesn't happen (e.g. you install on ad0 and the drive is ad2 on the "run" system) I have found it not very hard to work around.



  • I tried installing on another system and moving the drive over - didn't boot after move - couldn't find bootable media.

    Then I dl'd FreeBSD 7.1 and installed it.  Worked fine.  The only thing that was strange was the mention that the disk geometry was incorrect during the install.

    So I tried installing pfSense using the geometry FreeBSD used, didn't work either

    I can't understand how FreeBSD would install and not pfSense.  Now I'm trying to install pfSense on top of the FreeBSD, but I'm not really sure what I'm doing…



  • Installing pfSense on top of FreeBSD didn't work.  Probably didn't help that I didn't know what I was doing…



  • @3vian:

    I can't understand how FreeBSD would install and not pfSense.

    I'm not sure what version of pfSense you have been trying to install. pfSense 1.2.2 is based on FreeBSD 7.0. You successfully installed FreeBSD 7.1. That suggests it may be worth trying pfSense 1.2.3 (PRERELEASE-TESTING) which is based on FreeBSD 7.1.

    FreeBSD's hardware support sometimes lags that of other popular operating systems, particularly when encountering devices that don't quite behave according to specification or have their own unusual interpretation of the specification. I have two different types of USB adapters for notebook drives. One works well on FreeBSD, the three different versions of Linux I tried and Windows 2000. The other didn't work on FreeBSD 7.0 (frequently reported errors), didn't work on Linux 2.6.1x (can't remember the version exactly) but did work with Windows 2000 and Linux 2.6.2x (2x = 22 or 24 if I remember correctly). The second type was listed listed in a Linux driver file among types with "unusual" behaviour, the first type wasn't. You may have a similar sort of issue with your disk controller.



  • I've already tried 1.2.3 early.  Tried it again, still no luck.  I even tried 2.0.

    I would have given up by now and moved onto another distro, but I really want to run my pbx on my router.  I alreay have pfSense, trixbox, Windows 2008 and then my workstation - this is just for my home.  You can imagine the electric bill.  If I could get pfSense on this 1U server and then use the FreeSwitch package that would be great.



  • Lets try to simplify the situation. Can you boot FreeBSD 7.1 again and post the dmesg output so we get a report of what is in the system and FreeBSD's view of what is in the system.

    The Tyan Tiger i7501R motherboard looks as if its been around for a while so I would expect the FreeBSD support for the chipset should have been fairly well exercised by now.

    I've already tried 1.2.3 early.  Tried it again, still no luck.  I even tried 2.0.

    What exactly is the problem "tried it again, still no luck"? pfSense install completes? with or without GRUB? pfSense install fails? If so, what error?

    You earlier reported:

    I noticed that my bios seems to assign the HDD and CD to random channels after every bootup - something the hdd will be on 0 and then the next time on 3.

    Is this still happening? What report leads you to believe this is happening? (For example, if you boot FreeBSD 7.1 a few times is the hard drive sometimes reported as ad0 and sometimes as ad3?)

    What is your drive configuration: is the CD S-ATA or P-ATA? The hard disk is P-ATA?



  • Thanks for the all the help, but I've given up.  Or at least given up installng it directly.  I've installed VMware ESXi, so will see how that goes.



  • For what it is worth - I have this SAME motherboard… and I have solved the booting problem...

    I have a Single 40GB Sata hardrive.

    Here is what I did...

    1.)  Reset the bios to "load optimized defaults"

    2.)  Boot from the CD-ROM ( I confirmed this both with USB EXTERNAL AND IDE drives)

    3.)  Change your configs in the terminal to what you need them (i.e. setup the interfaces, ip addresses, etc...)

    4.)  Choose option 99 to install to hardrive.

    5.)  USING THE OPTIMIZED DEFAULTS IN BIOS, It finds my Single SATA drive as AD4.

    6.)  I choose this disk to install to.

    7.)  ACCEPT THE DEFAULT CONFIGURATIONS THAT THE INSTALLER PROPOSES (i.e. format using defaults, partition using defaults etc...)

    8.)  IMPORTANT - ONCE YOU GET TO THE BOOTLOCK SCREEN --- ACCEPT THE DEFAULT BOOTLOCK.

    9.)  Finish the install and reboot.

    10.) I unplugged my USB CD-ROM (and also unplugged an ide drive on 2nd install) after the machine rebooted...

    11.)  It booted right up into the BSD Terminal for me - NO ERRORS AT ALL...

    IF YOU NEED EXACT BIOS SETTINGS I SUPPOSE I CAN BOOT BACK IN AND LOOK AT THESE FOR YOU...  SHOOT ME AN E-MAIL OR PM...



  • Hello,
    Yesterday I had the same problem about
    booting the 1.2.2 version, but now I've installed
    it without any errors. What I did is set the harddisk
    parameter manually in the bios as freeBSD is
    reading it not correctly. I,m using the old p4 2.4GHZ
    on MSI Mobo.
    I just thought this might help.



  • Sorry for off topic, but I have SEVERAL of these server boards (the Tyan Tiger i7501R) – I am very interested to hear if you were able to install ESXi ???

    Please let me know either way!  Thanks!



  • Hey,

    I just experienced the same problem with 2 different laptop ide drives.  One is a 60gb Fujitsu, the other is a 80gb Seagate.  I tracked my problems down to the parallel ata cable.  I was using a 40 conductor because it didn't have the middle pin blocked out like the 80 conductress do and my laptop ide converter has that extra pin.  with the 40 conductor cable and a full 3.5" 10gb hard drive, everything worked fine.  I solved the problem by bending the extra pin out of the way on the adapter and upgrading to a 80 conductor cable.  I didn't read the entire thread so I'm not sure any of this will help you.  Now im running on a quiet, efficient, WAY OVER SIZED hard drive.  Guess that means i will have to increase the amount of space allotted to the proxy ;D  I just thought I would share my experience with the same error.

    Hope this helps and you don't give up on pfsense.  It is the best product out there for just about all applications.
    -V



  • HI all made a little progress with the Tiger i7501R board I got it to boot to the  welcome to pfsense
    where you can chose how to boot 1, 2, 3 and so on, but then it get to this line and seem to get stuck

    [boot/Kernel/acpi-ko text -0x525d0 data-0x23a0+0x186csymc=[0x4+0x8600+0x4+0xb0a]
    |
    |
    _ just blinks

    I disable CPU Hyper-Threading to get it boot to the above

    do any one have a !u server that boots all the way and can paste their bios settings here thanks



  • I was having a similar boot error on pfsense 1.2.2 after the full live CD ISO install:

    hptrr: no controller found
    ad4: FAILURE - SET_MULTI status=51 <ready,dsc,error>error=4 <aborted>My Hardware:

    Motherboard  SuperServer 5015B-MRB
    http://www.supermicro.com/products/system/1U/5015/SYS-5015B-MR.cfm

    Processor    Xeon Dual Core 3065 2.33 4M 1333fsb Boxed

    Memory    4GB (4 x 1GB) 667MHz DDRII Unbuffered ECC Memory

    I installed pfsense with no swap on a 40 Pin IDE 1GB Dual embedded disk module (SLC).

    http://www.innodisk.com/production.jsp?flashid=81

    I ended up changing the BIOS setting for this IDE ad4 device by entering the BIOS ~~and selecting:

    Ext. Primary Master [1048MB]

    and changing the settings from [auto] to [user]

    and changing the Transfer Mode to [FPIO 4 / DMA 2]

    and changing the Ultra DMA Mode to [Mode 4]

    After doing this, everything booted fine.

    -Will http://www.tranquilnet.com~~</aborted></ready,dsc,error>



  • I had this same problem also, it would get the FreeBSD boot loader after pfsense 1.2.2 installation and do a face plant at

    Default F1
    FreBSD

    /

    After reading this thread I played around with the BIOS settings which made no difference.

    I also tried installing FreeBSD 7.0-RELEASE and it worked fine.
    After installing FreeBSD 7.0 I tried to install pfsense over the existing partition without recreating it and that got me a little farther, I got past the boot loader however it couldn't find the kernel.

    Next I tried installing pfsense on a USB thumb drive, this method was able to boot!
    However using a 4GB thumb drive over the 250GB SATA hard drive in the server was not a viable solution for me.
    I booted off the thumb drive and changed /etc/fstab to point to the internal HD installation of pfsense, rebooted and crossed my fingers.

    I now have a working installation of pfsense running off the HD but booting off a 4GB  thumb drive
    I hope this helps someone else get past the booting problem, I know I spent a few days trying to get it to work right then gave up and made it work.  My pfsense server has been up and running for over 30 days with no problems, sorry for not posting my work around sooner.



  • I'd just like to say that I had the same problem and what solved it for me was resetting my BIOS settings to "Default Optimized Settings" , as an earlier post indicated.  I think what was this reset was the onboard RAID controller config that came with this mobo (about 5 years old – Gigabyte model).  I had messed with it years ago and changed the RAID mode for some reason.

    I know these aren't very useful details, but hopefully it can point some others in the right direction.



  • I had problems with my USP keyboard and some of my network cards. I´ve tried every solution that the forum could provide and then i accidentally read about the 1.2.3 version.

    http://blog.pfsense.org/?p=377

    This solved all my problems! The even the USB keyboard is working without any workaround.



  • I think I got the answer just go to the bios and disable the keyboard num lock option an then install pfsense again ..  :P



  • I have an ASUS P5LD2-VM motherboard, installing version 1.2.3, 300GB SATA drive, and was having these problems as well.  I enabled "Compatability Mode, PATA+SATA" in the BIOS setting and this didn't fix it, but did change the device from ad10 to ad2.  I then specified during a new install ~10GB for first partition (and the remaining 280GB for second partition), and cleared the "Packet Mode" check box in the Bootblocker installation dialog.  It works now.  I'm not sure if it was the smaller partition size (I was just doing a 300GB, entire drive partition) or if clearing "Packet Mode" during install that did the trick.



  • I just wanted to share my experience. My friend and I both have a system based on an older Intel D915PGNL 915P motherboard with SATA drives. Accepting the defaults during install would result in pfSense hanging while trying to boot off of the HDD. I upgraded to the latest bios and loaded system defaults, this had no effect, enabling legacy HDD mode did not help either. After reading some threads in the forum, I decided to partition my 160gb drive and disable 'packet mode', I gave the primary partition 20gb and allocated the rest to the second partition. Once this was done everything booted up properly.

    Light



  • This topic is old.  However folks seeing problems should check this document out: http://doc.pfsense.org/index.php/Boot_Troubleshooting


Log in to reply