Steam, Uplay and missing logs



  • I'm attempting to use steam again after a little time (last use was pre-pfsense) and I installed Uplay fine but now that it's come to installing Steam, it's having loads of problems and can't even log in. When looking at the firewall rules and Suricata rules (only services I'm running other than OpenVPN) there are no logs that say anything about blocking steam which is why I'm a bit stuck.

    Could anyone lend a hand?

    thanks for your time,

    John.



  • Dead as fuck, apparently noone visits this part of the forum. Feelsbadman



  • Most people I know here use pfSense in a professional setting where gaming isn't part of the requirements.  Also, you posted on a weekend when a lot of regulars aren't paying attention.  Lastly, there was a major release late last week that is sucking up a lot of the support oxygen.

    I don't do any gaming myself.  That said, I seem to recall that most errors related to gaming with pfSense have to do with static ports on the outbound NAT.  Read some of the other problems/solutions here as I'll bet a lot of them are related to your problem as well.



  • What I did was to create an alias for each game/game service, with all their port numbers, for the firewall, then created a rule using each, to keep things tidy and easy to change per service if they change ports.  I tested with that only, no snort or squid or anything else.  Once all was working correctly, I then added squid and squidguard.  Once that was tuned, I added snort and tuned that up.  If I had put all three in there at once I would never have been able to figure out just what was doing what if something wasn't working.  So I would disable Suricata or set the default allow-all out the firewall lan interface, and test.  If it works, at least you have narrowed it down to what you had disabled, firewall rules or Suricata.