Help setting this up?

  • I have been struggling with this for a few days.  I have looked at both the m0n0wall and the pfSense documentation, trying different setting, etc.

    Here is what I have:

    Speedstream 5660 –> pfsense -->  Wired PCs on subnet  (LAN)
                              2wire 2700 on (opt1)

    The 2wire 2700 is an "intelligent gateway" (WHY do they have to call it that?) with a DSL modem, 4 port switch, and 802.11 b/g all in one.  UGH!!!!  took me a while to get a hold of someone who could finally tell me how to put the damn thing into bridge mode.  It is passing all traffic from the LAN to the wireless, no routing/NAT.  It is, however, still assigned an (unchangable in the bridge configuration) IP address of

    What I would like to do is enable the captive portal on the OPT1 inteface, and use the built-in user manager.  I have already created a user/password, after enabling the captive portal.

    The OPT1 interface is NOT bridged to LAN< and I have used the "Create a firewall rule based on this one", selecting the default LAN rule as the model.  I changed the IP interface, and saved the rule.  I then enabled the DHCP service for the interface, and assigned the range of IPs that it should hand out.  From what I can tell, with there not being any actual documentation on how to set this up, I would think that things would work.

    If I disconnect the LAN cable from my laptop, and enable the wireless card, the wireless card connects, and gets assigned an IP address of, which is the correct range for that interface.  However, whenever I try to test web browsing (I am using FireFox, if it makes a difference) the request just times out.  No captive portal page, no popup asking me to authenticate, nothing.

    Any help is apprecaited.  Once I get this worked out, I have an advanced config I will want to get going, but just need this working for now.



  • You have the portal set to be enabled on the opt1 interface?    Did you add a rule to allow that subnet out of the firewall?  By default it won't allow traffic on that interface to pass.  You need to add an allow rule under Firewall -> Rules -> opt1

    Have you tried removing the 2wire device and testing with just a wired connection either directly into the pfsense box or through just a hub or switch?  I had nothing but bad luck with those 2wire devices 3-4 years ago when I tested them as DSL CPE.

    Something else to try, can you go to ? (assuming that the opt1 address is

    I just set this up to test and it works fine for me (minus the 2wire device).  I'll wager you just need a pass rule for that subnet on that interface.

Log in to reply