RESOLVED-Two APs-one on LAN and the other on OPT1(no internet on OPT1 wireless)



  • Hi,

    I am new to pfsense!

    I have two LANs, LAN and OPT1. I have set DHCP, firewall rules etc.

    I have a AP on LAN and I want another AP on OPT1. When I added the AP to OPT1, wireless clients connects to AP, but there is no internet. Whereas wired clients get internet. Why is it so? Please help.

    Nat

    ![pfsense 1.jpg](/public/imported_attachments/1/pfsense 1.jpg)
    ![pfsense 1.jpg_thumb](/public/imported_attachments/1/pfsense 1.jpg_thumb)
    ![pfsense 2.jpg](/public/imported_attachments/1/pfsense 2.jpg)
    ![pfsense 2.jpg_thumb](/public/imported_attachments/1/pfsense 2.jpg_thumb)


    ![Problem diagram.PNG](/public/imported_attachments/1/Problem diagram.PNG)
    ![Problem diagram.PNG_thumb](/public/imported_attachments/1/Problem diagram.PNG_thumb)



  • Outbound NAT?

    Edit: Never mind you said Wired Clients (assuming connected to same layer 2/VLAN/Interface) can get internet.



  • What kind of AP is that (real AP or router with WLAN) and how is it connected to your OPT1 interface/sswitch?



  • Hi Chris,

    The AP is a Netgear wireless router configured to AP mode. It is connected to OPT1 directly via network cable. The router end of network cable goes to one of the 4 LAN ports, not the internet port.

    Thanks

    Nat



  • If you swap AP on LAN with AP on OPT1 and does the problem follow AP?



  • Good point, gjaltemba!

    I will try this evening and post the result here.

    Thanks

    Nat



  • Do you see all client's DHCP leases on Opt1 in pfSense?



  • Thanks gjaltemba and Chris!

    I swapped the routers and found the AP on OPT1 was not working under LAN too. I checked the AP setting where I had configured for static ip, 192.168.50.2 and the gateway as 192.168.50.1 and primary DNS was 192.168.50.1. I thought this could have caused issue and made it as auto IP. To be safe I reset the router.

    The two settings, I guess, would have caused the issue are:

    1. Primary DNS was 192.168.50.1

    2. Wireless Isolation (checked) in the wireless settings.

    However the issue is resolved. I appreciate your help. You made me think and try different options.

    Nat


Log in to reply