SquidGuard non funziona al riavvio



  • Hola a todos,

    questo è il mio primo post qua, anche se seguo da parecchio tempo pfsense e l'ho usata svariate volte (per lo più usando oltre al firewall squid in modalità trasparente e il captive portal).

    Mi succede una cosa strana, squidGuard, subito dopo che riavvio la macchina, non mi effettua il filtraggio dei contenuti mentre se premo, dalla gestione del pacchetto, prima APPLY e poi SAVE tutto funziona regolarmente.

    Attualmente la macchina è configurata con su squid in modalità trasperente, con squidguard con la redirezione ad una pagina di errore esterna, dato che il ridirezionamento interno non funziona in modalità trasparente. E' attivo anche il DHCP, il DNS Forwarder e il Captive Portal che sfrutta FreeRadius per l'autenticazione degli utenti. La GUI web gira sotto HTTPS, ma non mi ha mai dato problemi.

    Subito dopo il riavvio squidguard è, normalmente, in esecuzione (ps -A | grep squid) e figura correttamente anche nella configurazione del file di squid (/usr/local/etc/squid/squid.com)

    Questa è l'acl di default di squidguard

    
    acl  {
            #
            default  {
                    pass !blk_blacklists_ads !blk_blacklists_aggressive !blk_blacklists_audio-video                                                               !blk_blacklists_drugs !blk_blacklists_gambling !blk_blacklists_hacking !blk_blacklists_mail !b                                                              lk_blacklists_porn !blk_blacklists_proxy !blk_blacklists_redirector !blk_blacklists_spyware !bl                                                              k_blacklists_suspect !blk_blacklists_violence !blk_blacklists_warez all
                    redirect http://10.0.0.254:8000/captiveportal-error.php?url=&a=%a&n=%n&i=%i&s=%                                                              s&t=%t&u=%u
                    log block.log
            }
    }
    

    Il redirect l'ho fatto sfruttando l'upload dei file del captive portal

    Mentre qui c'è il blocco delle opzioni di redirect

    
    # Custom options
    redirect_program /usr/local/bin/squidGuard -c /usr/local/etc/squidGuard/squidGuard.conf
    redirector_bypass on
    redirect_children 3
    
    

    Ci combatto da ieri pomeriggio e sinceramente non ho proprio idea di cosa possa essere! Cosa potrei fare?


Locked