LightSquid v1.8 перестал работать



  • Привет всем.

    Коллеги, подскажите где копать: 30, 31-ого марта LightSquid отображал статитсику.
    Апрельской статистики нет =( Просто пусто.

    Как посмотреть в какой момент выключился LightSquid и почему?

    P.S. Разобраться бы один раз и на всегда. Пока тёмный лес.



  • смотрели обновления пакета?



  • @derwin:

    смотрели обновления пакета?

    Вроде бы, последняя версия. "LATEST : V1.8 see online DEMO V1.8 or Download V1.8
    "



  • Добрый.
    В любой непонятной ситуации искать и читать логи.



  • @werter:

    Добрый.
    В любой непонятной ситуации искать и читать логи.

    сижу в логах системы.. посоветоваться не с кем =( кроме как с гуглом =), но он плохо говорит по русски, а я по английски.

    В каких именно логах смотреть? (Статус-систем лог? может есть ещё логи?)



  • @werter:

    Добрый.
    В любой непонятной ситуации искать и читать логи.

    Может я неправ –- но Lightsquid вроде свои логи не пишет

    Если я неправ ??  покажите где они находятся  ;D

    ===============================================================

    P.S

    Jon_777

    Попробуйте переустановить lightsquid

    И СДЕЛАТЬ REFRESH FULL



  • 1. Status: Services  squid работает?
    2. Proxy Server: General Settings  Enable Access Logging  галка стоит?

    3. Status Squid Proxy Reports: Settings  Instructions  - перепроверь все как надо?



  • @NegoroX:

    1. Status: Services  squid работает?
    2. Proxy Server: General Settings  Enable Access Logging  галка стоит?

    3. Status Squid Proxy Reports: Settings  Instructions  - перепроверь все как надо?

    Первые два пункта - да, галочка стоит.
    3 пункт. "перепроверь все как надо" - Проверяю.

    Посмотрите, пожалуйста на часть конфигурации прокси.
    Есть что-то ненормальное?
    после "//" я написал моё понимание данной строки

    logfile_rotate 90    //90 дней хранятся в логе
    debug_options rotate=90
    shutdown_lifetime 3 seconds      //время обновления данных в логе

    Allow local network(s) on interface(s)

    acl localnet src  192.168.1.0/24 127.0.0.0/8
    forwarded_for on
    uri_whitespace strip

    acl dynamic urlpath_regex cgi-bin ?
    cache deny dynamic

    cache_mem 64 MB
    maximum_object_size_in_memory 256 KB      //можно и 10 Мб поставить, чтобы из кеша выудить такие файлы
    memory_replacement_policy heap GDSF
    cache_replacement_policy heap LFUDA
    minimum_object_size 0 KB
    maximum_object_size 4 MB
    cache_dir ufs /var/squid/cache 3000 16 256      //я задал 3000
    offline_mode off
    cache_swap_low 90
    cache_swap_high 95
    cache allow all

    Add any of your own refresh_pattern entries above these.

    refresh_pattern ^ftp:    1440  20%  10080
    refresh_pattern ^gopher:  1440  0%  1440
    refresh_pattern -i (/cgi-bin/|?) 0  0%  0
    refresh_pattern .    0  20%  4320



  • в сквиде закладка
    Proxy Server: General Settings
    Log Store Directory  /var/squid/logs
    есть такая запись?



  • Да есть. (отсюда он логи тащит, это понятно)
    Но разве это нормально, что в этой папке лежат файлы ~16 файлов (называются как цифры в шестнадцатиричном коде: ~ 00 01 02 03..aa) - дата изменения у них 31 марта!
    Лог должен пополняться ежедневно, следовательно дата должна быть актуальной.
    Соответственно, Lightsquid, скорее всего,  работает . У него просто нечего обрабатывать. Логи-то старые.

    т.е. Почему могут перестать писаться логи?



  • Добрый.
    Проверьте свободное место в системе.

    Зы. Как вариант - удалить, почистить хвосты, переустановить пакеты.



  • "Дело было не в бабине…"
    Места на диске предостаточно (использован только один процент).
    Эксплореру прописал руками использование прокси - и Пошли превышения ожидания. Пропал интернет. И логи появились :(((
    Т.е. прокся настроена неправильно
    всё снесу и заново переустановлю. (столько вариантов попробовал, что проще заново всё переделать).

    Изначально был транспарент прокси. http - не работал!Работал только https, и то потому, что он не протоколировался (а не протоколировался (не велся его лог) https потому, что сертификата не было).

    Сертификат сделал по инструкции.
    Снял галку с transporent proxy
    и появился инет на всех машинах: и http и https
    Скорее всего, машины не авторизуются на прокси и валят в инет через шлюз (не взирая на прокси. соответственно прокся не ведёт логи, потому, что её не используют)
    Как узнать, работает ли прокси?      (в статусах, всё "работает")


Log in to reply