Traffic shaping wizard not working



  • I have PFSense 2.4.3 x64 running in a VM on a server running ESXi 6.0. I just recently updated PFSense through the gui to 2.4.3. I had a traffic shaper policy applied via the traffic shaper wizard. I removed it because I wanted to make some adjustments, however I could not run the wizard once I removed the shaper. I kept getting this error "This firewall does not have any LAN-type interfaces assigned that are capable of using ALTQ traffic shaping." And "The specified number of connections is greater than the number of ALTQ-capable assigned interfaces!" I am not sure what ALTQ is and I haven't used it. I have been using HFSC. But I cannot continue with the wizard because it keeps giving me this error. I did not have any problems before this. Has anyone run into this problem before or have any suggestions for me?

    I have tried restarting the main esxi host as well as the VM and neither has worked.

    I have 1 WAN interface and 3 LAN interfaces that are VLANS.

    I also have intel E1000 emulated NICs which are supposed to support ALTQ shaping.

    Thanks



  • I also switched to VMXNET3 adapters and it still gives me an error of no adapters found that could support ALTQ shaping.



  • I am using esxi 6, no problem with the wizard, although I upgraded it to 2.4.3-RELEASE, not fresh install. Can you show the interface assignment?



  • I will get a capture of the interface assignments. I originally clean installed it with 2.4.2 and then applied a shaping policy through the wizard. I upgraded to 2.4.3 and then removed the policy to adjust it. When I went back to apply a policy through the wizard, that is the error I get.



  • Attached is the interfaces section




  • Quite different from my setup it seem, I am using VMware networking to manage my VLAN thus all my ethernet interface have MAC addresses on the interface assignments of pfsense. I am not sure exactly why yours is not working maybe because no MAC address on your interface?



  • It should still work though because the actual interfaces being USD have MAC Addresses. The VMX0 and VMX1 should have Mac addresses. Anything sent to any of my VLANs that are destined to the router will always use the destination MAC of VMX1, but to specify the VLAN, it uses the 802.1Q standard and applies a frame VLAN tag to separate the traffic and have it be on a separate network.



  • Go to Firewall -> Traffic Shaper and make sure all shapers are removed. Did you define a gateway on your LAN interfaces, if yes pfSense will treat them as WAN interfaces and the wizard will not accept them as a LAN.



  • I went to firewall -> traffic shaping and clicked "remove shaper" but this did not fix the problem. I also went to every interface and clicked "disable shaper" but it still didn't work. I also do not have any upstream gateways assigned to any interface and my WAN interface is using DHCP.



  • @clifford64:

    I also went to every interface and clicked "disable shaper" but it still didn't work.

    You need to remove/delete them, not disable them.



  • There doesn't seem to be a remove option when looking at them. Attached is what I see. The interfaces are all the same so I only posted one.

    ![pfsense_traffic shapping interface.PNG](/public/imported_attachments/1/pfsense_traffic shapping interface.PNG)
    ![pfsense_traffic shapping interface.PNG_thumb](/public/imported_attachments/1/pfsense_traffic shapping interface.PNG_thumb)
    ![pfsense_traffic shapping.PNG](/public/imported_attachments/1/pfsense_traffic shapping.PNG)
    ![pfsense_traffic shapping.PNG_thumb](/public/imported_attachments/1/pfsense_traffic shapping.PNG_thumb)



  • @clifford64:

    Attached is the interfaces section

    Can you try to assign the unused interface too and retry the wizard.



  • Like assign the VMX1 interface to a network? Or something else?



  • Just use the green button +add, see what happens.



  • @0t73r:

    Just use the green button +add, see what happens.

    I added VMX1 by clicking the "add+" button in my interfaces, and now it is a new interface on opt4. Running the traffic shaping wizard still doesn't work. I tried changing it to 1 lan and wan and it still didn't work.



  • I am having exactly the same problem with a physical machine on 2.4.3.
    I needed to disable traffic shaping because of a configuration change.
    I removed the <ezshaper>section of the configuration backup and restored the configuration, to no avail sadly.</ezshaper>



  • Bump, anyone got any ideas? Is the next preview build stable enough? This is currently a home environment.



  • @clifford64:

    Bump, anyone got any ideas? Is the next preview build stable enough? This is currently a home environment.

    When I was using 2.3.x, the development branch was fairly stable. I am using the stable branch now though.
    Currently, there is no indication that this is officially a bug @ https://redmine.pfsense.org/projects/pfsense/roadmap. So I doubt it would make any difference to use the development branch.
    However, I think the error occurs because the traffic shaper did not get deleted correctly in both our cases.
    I think we both would have to set up everything from scratch, because trying to delete a traffic shaper actually seems to cause one not to be able to set up a new one…
    Too bad I don't have time to test this at the moment.



  • @phming:

    @clifford64:

    Bump, anyone got any ideas? Is the next preview build stable enough? This is currently a home environment.

    When I was using 2.3.x, the development branch was fairly stable. I am using the stable branch now though.
    Currently, there is no indication that this is officially a bug @ https://redmine.pfsense.org/projects/pfsense/roadmap. So I doubt it would make any difference to use the development branch.
    However, I think the error occurs because the traffic shaper did not get deleted correctly in both our cases.
    I think we both would have to set up everything from scratch, because trying to delete a traffic shaper actually seems to cause one not to be able to set up a new one…
    Too bad I don't have time to test this at the moment.

    Do you have any documentation on where I might find the commands to configure and delete traffic shapers?



  • @clifford64:

    @phming:

    @clifford64:

    Bump, anyone got any ideas? Is the next preview build stable enough? This is currently a home environment.

    When I was using 2.3.x, the development branch was fairly stable. I am using the stable branch now though.
    Currently, there is no indication that this is officially a bug @ https://redmine.pfsense.org/projects/pfsense/roadmap. So I doubt it would make any difference to use the development branch.
    However, I think the error occurs because the traffic shaper did not get deleted correctly in both our cases.
    I think we both would have to set up everything from scratch, because trying to delete a traffic shaper actually seems to cause one not to be able to set up a new one…
    Too bad I don't have time to test this at the moment.

    Do you have any documentation on where I might find the commands to configure and delete traffic shapers?

    That, or any relevant configuration files is what I've been searching for the last few days. I'm afraid I have no answer to this (yet).
    Of course it would be nice if a developer could provide some insights on this.



  • Or maybe someone else has an idea what to do? I'd be curious to know how reset any traffic shaping related configuration manually too.



  • Any interface with a non-empty "IPv4 upstream gateway" is considered a WAN interface. The Wizard refuses to work if there're no LAN interfaces.

    Therefore, in order to configure/reconfigure the Traffic Shaper via the Wizard, there must be at least one LAN-type interface, i.e. one without "IPv4 upstream gateway".



  • @dusan:

    Any interface with a non-empty "IPv4 upstream gateway" is considered a WAN interface. The Wizard refuses to work if there're no LAN interfaces.

    Therefore, in order to configure/reconfigure the Traffic Shaper via the Wizard, there must be at least one LAN-type interface, i.e. one without "IPv4 upstream gateway".

    The only interface that has an upstream gateway configured is my WAN interface. I have left it to use DHCP and it acquires all information that is needed. All other interfaces are LAN interfaces and they do not have any upstream gateways configured.



  • Sorry. I've tried to reproduce the error but I can't. The Wizard works repeatedly on every possible VLAN configuration I tested. It works repeatedly even in case of untagged VLAN. (See attached figures.)

    Tested on ESXi v.5.5.






  • Thank you for your posts.
    I don't know how / why this might make any difference, but both of you seem to be using VLANs.
    Does my LAN interface need to be a VLAN in order to use the traffic shaper?
    My LAN technically is on a VLAN too, but it's an untagged port.



  • @phming:

    Does my LAN interface need to be a VLAN in order to use the traffic shaper?

    I don't think so. Attached figure pfsense_lab_config1 (see my previous post) shows that the LAN interface can be untagged VLAN.



  • Ok, sorry I didn't look closely enough.
    I recently restored my config onto a VM because of a hardware failure of my main system ::) and was able to configure the traffic shaper using the wizard flawlessly… Now of course this time the interface names changed from ixl and igb to all vmx.
    I'll report back as soon as my main box comes back repaired and when I've had time to configure it from scratch.



  • I would rather not have to reinstall pfsense and restore my config. I would really like to figure out what went on. Can anyone point me in the direction of command line documentation so I can take a look into this? Or any other ideas. I am really just trying to keep this thread alive.



  • So my board came back and my bare metal pfsense is up and running again, installed from scratch. I remain unable to set up a new traffic shaper configuration with 2 WAN and 1 LAN interfaces.



  • I think I might have found the reason for this (at least on my end). System logs show the following message:

    rc.bootup: The gateway: WANGW is invalid or unknown, not using it.
    

    Neither of my gateways are named WANGW. Now do I really have to change one gateway's name back to WANGW?

    ??