Enable Squid proxy for remote networks



  • Hi all,

    I configured Squid as web proxy and it worked properly on interfaces directly connected to pfSense. However, when I enabled it for remote subnets, I got this error message: "The requested URL could not be retrieved - Access denied".

    My topology: WAN –--- pfSense -----L3 connectivity ----- L3 switch (used as default gateways for subnets - these networks received error when enabling Squid)
                                            |
                                            |
                        interfaces directly connected to pfSense (working properly when enabling Squid)

    My questions: Can we enable Squid proxy for remote networks on L3 switch as in my topology? If yes, how do I configure it?

    Thanks for reading and all comments are much appreciated!



  • Solved!

    Add allowed networks in Services –> Squid Proxy Server --> ACLs --> Allowed Subnets

    :)