Broken WEB GUI



  • For the past week I've been experiencing a broken GUI (no top bar, just everything listed vertically) just as described (and solved) in this other post: https://forum.pfsense.org/index.php?topic=145077.0

    Unfortunately that solution has not worked on my machine. I have tried other machines, ones that have never visited the web gui, and restarted the firewall, but to no avail.

    It appears like the bootstrap scripts fail to load. Is there a chance that these scripts got corrupt on the firewall? How can I replace these files?

    Is it a coincidence that I'm not the only user to have this issue in the same week?

    Thank you in advance for your answers.



  • Digging further I have just noticed that inspecting the WEB GUI page Chrome reports a few errors. See attached.




  • Maybe your install is borked?  Export your config, wipe, reinstall, import config.



  • Thanks for replying,

    maybe you are right. Just checked the  /usr/local/www/vendor/bootstrap/  and it is completely empty. Is that normal?

    I have been planning to upgrade to a SSD drive in the future, so this might be a sign that the time has come.  ???



  • Is that normal?

    No.  You're missing your css and js folders.