Alix 2d3 & Atheros issues



  • Hi,

    I've got some problems to get wifi working on my alix 2d3 board with an Atheros based Compex WLM54G card and 2 antennas.  After searching this forum for a while it seems to me that I'm not alone with these rx-errors and that there is no real solution, but maybe I missed something. I would buy another card at once if that could help, but since there are no real alternatives to the atheros cards and a lot of other people seem to have these issues I'm not sure if that would change anything.

    I installed 1.2.1 first and activated WPA-2 encryption. I've got two clients, a laptop with a Intel based wifi card and a mobile phone with a broadcom chipset and windows mobile. The Laptop seems to work work fine most of the time, but it suffered from from bad ping times and sometimes the connection seemed to stall for some seconds. The phone connected to the network and got an ip from the dhcp server, but it would not transfer any data. In the log files a "deauthenticated due to local deauth request" message was logged many times and the rx-error count was very high.

    After that I deactivated the encryption and tried out every possible combination of dev.ath.0.txantenna, dev.ath.0.rxantenna, dev.ath.0.diversity and txpower. I even changed the pigtails and the two antennas, but it didn't get any better. I also installed 1.2 and 2.0 alpha, but every combination gives me rx-errors. The name of these errors changes though, 1.2 gives rx fifo errors, 2.0 generates PHY errors:

    # athstats
    1194 data frames received
    958 data frames transmit
    13 tx frames with an alternate rate
    817 long on-chip tx retries
    165 tx failed 'cuz too many retries
    54M current transmit rate
    483 tx management frames
    268 tx frames discarded prior to association
    51 tx frames with no ack marked
    873 tx frames with short preamble
    3673 rx failed 'cuz of bad CRC
    73966 rx failed 'cuz of PHY err
        13499 OFDM timing
        60467 CCK timing
    22622 beacons transmitted
    134 periodic calibrations
    64 rssi of last ack
    53 avg recv rssi
    -96 rx noise floor
    1 cabq frames transmitted
    50 switched default/rx antenna
    Antenna profile:
    [1] tx      583 rx     2023
    [2] tx      287 rx      892
    
    

    It still seems to work somehow, but using ping I get about 10% package loss to my laptop and 96% package loss to my phone. Everything is on my desk and I tried channels 1,6,11 and auto. Is there anything else I could try to make this work? I don't want to install ipcop or use an external ap.



  • I have similar issues with ALIX2C2 with wistronCM9 card (Atheros5213 according to specs , but recognized as 5212).
    The signal is very weak compared to my other router sitting nearby (50-55db for it and only 25-30db for the pfsense).
    It did work for one day pretty good then I got a bunch of beacon stuck messages and AP stopped working at all.
    After some fiddling I found out that g doesnt work well and had to drop to 11b.
    It is more stable now but the signal is still very weak and there are lots of in/out errors.



  • Just purchased an alix 2d3 and an atheros Wistron CM9 mini pci card and I can't get wireless working at all with either B or G. I get no signal. I followed the setup tutorial several times. Anyone have any more suggestions on this?



  • @ashdavely : find a solution to your problem ?
    I forced the channel (6) then all ok for me.


Log in to reply