FYI: ESX 6.7 Compatibility


  • Rebel Alliance Developer Netgate

    I upgraded my ESXi host from 6.5 to 6.7 today and everything works fine, no problems at all. I upgraded my pfSense lab VMs to the latest hardware compatibility ("ESXi 6.7 and later (VM version 14)"), and now can set the guest OS to Other/"FreeBSD 11 (64-bit)". When set that way, ESXi no longer complains about the tools version mismatching.

    So as far as I can tell, it's been a very boring upgrade. My favorite kind.

    Of course YMMV so be sure to take backups and be ready in case it doesn't go so smoothly for you.

    Also FYI: ESXi 5.5 will be EOL this September and there is no direct path from 5.5 to 6.7. You'll need to make a stop at 6.0 or 6.5 along the way.

    As usual, online upgrading via SSH using the imageprofile command examples from https://esxi-patches.v-front.de/ worked flawlessly.



  • Thanks for the tip.

    I just did a scan yesterday with Update Manager and it didn't find this 6.7 release.  Time to do some reading…



  • Awesome, great to hear that the pesky vmware tools message is going to disappear. I should be carrying out the upgrade soon after backing up my ESXi host.

    It's quite interesting that Jim uses ESXi… Maybe that's why it's been so stable for me  ::) ::) ::)