Multiple clients can connect but only first one works

  • Like the title says, I have setup openvpn server (Multiple times through tutorials) and have the same issue.  I can connect with PC1 and laptop1 no problem.  BUT, whichever connects first works fine, can browse network and internet no issue.  Which ever one connects second, has nothing.  No local browsing, no internet.  Nothing.

    The IP address of my OpenVPN is and they get assigned .2, .3, .4 and so on.  .2 always works, anything after it does not.

    I have separate users and certs for each user using the server cert to create them.  So each device is not using the same user/cert as the other-Totally separate.  I have set concurrent users to 50, even though I am only using 2.

    Does anyone have any guidance at all as to what I am doing wrong?


  • If anyone has this same problem, here is the fix-

  • i have tried that but still not working :(

  • Try a reboot after.  That's what I needed to do for mine after selecting that.  You may also want to clear your state tables (Not sure if they have any influence) in case there are any hanging states left over.

  • LAYER 8 Netgate

    Nonsense. That checkbox is almost never required. In fact, I don't think I have ever seen a case where anyone has run into that.

    You did not say what KIND of OpenVPN server you made. Remote Access? Site-to-Site? What kind of clients are connecting? From where?

  • LAYER 8 Netgate

    What are the rules on the OpenVPN tab and the OpenVPN assigned interface tab, if any?

  • LAYER 8 Netgate

    Most of those rules on OpenVPN are completely unnecessary but they are disabled. The one you have enabled is fine.

    The only rule on WAN that matters is the one that passes the OpenVPN (1194) traffic itself.

    It looks like you have everything you need there.

    Probably time to pcap on the openvpn interface, the local interface, and see what is actually flowing where.

  • LAYER 8 Netgate

    Don't capture on WAN, Capture on OpenVPN and on LAN.

  • I had a similar problem during my migration from Tomato to pfsense.

    Turned out this was due to multiple Default Routes in the Routing Table.

    All fixed with the help of @johnpoz. You might want to check that?

Log in to reply