2.4.3 Captiveportal Login Sayfası Gelmiyor



  • merhabalar. yaklaşık 2 yıldır pfsense 2.3.1 üzerine kurulu freeradius ve captiveportal ile sorunsuz bir şekilde çalışıyorduk.
    bu sabah 2.4.3 sürüme güncelledim sorunlar yaşıyorum. en büyük sorunum tarayıcının açılış sayfası https ise captiveportal login ekranı gelmiyor.
    2 defa tekrar kurdum yine aynı sorun. pfsense 2.3.5 yükledim, yine aynı sorun. bu sorunun bir çözümü var mıdır?



  • @oguzk06:

    merhabalar. yaklaşık 2 yıldır pfsense 2.3.1 üzerine kurulu freeradius ve captiveportal ile sorunsuz bir şekilde çalışıyorduk.
    bu sabah 2.4.3 sürüme güncelledim sorunlar yaşıyorum. en büyük sorunum tarayıcının açılış sayfası https ise captiveportal login ekranı gelmiyor.
    2 defa tekrar kurdum yine aynı sorun. pfsense 2.3.5 yükledim, yine aynı sorun. bu sorunun bir çözümü var mıdır?

    Bu versiyonda bug var.

    https://redmine.pfsense.org/projects/pfsense/repository/revisions/8228ea91f44c3d9280e15306f00e0ebe8d0f5aa9

    /etc/inc/captiveportal.inc dosyasını yukarıdaki adresteki ile değiştirin yada farklar olan linke tıklayıp kırmızı ile işaretlenmiş olan satırın yerini değiştirin. daha bir çok bug var, geçtiğime pişman oldum



  • İş yerine geçiyorum. Deneyip sonucu yazarım. Olmaz ise 2.3.1 e tekrar döneceğim, daha fazla uğraşmak istemiyorum. Bilgi için teşekkür ederim.



  • @oguzk06:

    İş yerine geçiyorum. Deneyip sonucu yazarım. Olmaz ise 2.3.1 e tekrar döneceğim, daha fazla uğraşmak istemiyorum. Bilgi için teşekkür ederim.

    Freeradius3 te attribute değişmiş bu arada. sorun ondan da kaynaklanabilir. radcheck tablosunda attribute Cleartext-Password olarak değişti.



  • yok işe yaramadı.
    açılış sayfası http ise sorun yok, ama https ise login ekranı gelmiyor. :(



  • HTTPS'e daha önce geliyor muydu?
    HTTPS'e gelmemesi normal. paket içeriğini göremiyor ki? firewallunuzun adresi https ile mi yapılıyor?



  • daha önce 2.3.1 kuruluyken, kullanıcı internete girmek istediğinde eğer captiveportal ile login olmamışsa chrome,firefox veya ie farketmiyor, tarayıcısını açtığında direk captiveportal login sayfası geliyordu. şimdi eğer kullanıcı bilgisayarın tarayıcının açılış sayfası https bir sayfa ise mesela google, captiveportal login sayfası gelmiyor. internet bağlantısı yok diyor kalıyor. ama adres satırına https olmayan bir sayfa mesela www.maliye.gov.tr yazıp entere bastığımda captiveportal login sayfası geliyor.



  • Hocam bu yaşadığınız durum normal. eğer captiveportal erişim adresiniz doğrulanmış bir bir sertifikaya sahipse, (misal captiveportal erişim adresiniz https://firewall.domainadiniz.com) https çıkışınızda captiveportal bunu görüp kullanıcı adı ve parola sorabilir. fakat değil ise erişim isteğini anlayamayacağı için dönüp durur. sanıyorum hepimizin muzdarip olduğu bir konu bu.



  • şaşırdım açıkcası. bugüne kadar nasıl kullandık biz o şekilde sorunsuz bilemiyorum şu an.





  • 2.3.1 sürüme geri döndüm ama maalesef eskisi gibi çalışmıyor. O zaman nasıl çözdüğümü de hatırlamıyorum.  Https açılış sayfası olan tarayıcılarda login ekranı gelmiyor.
    ssl sertifika alarak ve dns server kurarak bu sorunun çözüldüğü yazılmış bir yerde. bu konuda bilginiz var mı, nasıl yapılacağına dair?



  • Captive portal ayarları içerisinde

    "Pre-authentication redirect URL"

    kısmına http ile başlayan bir adres yazmayı deneyin.

    "After authentication Redirection URL" kısmınada giriş başarılı olduktan sonra kullanıcıların yönlendirileceği adresi girin google.com gibi.

    Emin değilim ama çözüm olabilir.



  • yok maalesef işe yaramıyor o yönlendirmeler.



  • bu sorunun ücretlide olsa bir çözümü yok mudur arkadaşlar?