Telekom Entertain (Magenta M TV) über BNG mit pfSense läuft nicht am Switch



  • Liebe Gemeinde,

    hier wurde ja schon wiederholt über Probleme mit dem Triple-Play-Angebot der Telekom berichtet.

    Das tue ich aus gegebenem Anlass jetzt auch. Die einschlägigen Forenberichte hier, bei "Telekom hilft" und insbesondere die Anleitungen hier

    Fehlerbeschreibung:

    Entertain funktioniert nicht, wenn ein IGMP-v3-fähiger Switch dazwischenhängt (der korrekt konfiguriert sein sollte).

    Details:

    Telekom Anschluss: Magenta M (50 MBit VDSL) über BNG mit EntertainTV (also alles über VLAN 7).

    WAN / Internet
                :
                : DialUp-/PPPoE-/ Telekom Magenta M 50 MBit VDSL BNG Triple Play
                :
          .–---+-----.
          |  Modem    |  DrayTek Vigor 130 (Bridge-Modus, setzt VLAN-Tag)
          '-----+-----'
                |
            WAN, VDSLMODEM
                |
          .-----+-----.  OPT1            .------------.          .------------.
          |  pfSense  +------------------+ Switch      |--------+ Client      |  pfSense v. 2.4.3-RELEASE (amd64)
          '-----+-----' 192.168.1.0/24  '------------'          '------------'
                |
            LAN | 192.168.0.0/24
                |
          .-----+---------.
          | LAN-Switch    |  Zyxel GS1910-24 (IGMP v3 fähig, letzte Firmware)
          '-----+---------'
                |
        ...-----+------... (Clients/Servers)

    Das Modem (DrayTek Vigor 130) ist im Bridge-Modus, setzt den notwendigen VLAN 7 Tag und der Haken beim Easy Login im Telekom-Kundencenter ist aus. VDSL geht mit > 47 von 50 MBit.

    Der pfSense-Router übernimmt die Einwahl über PPoE mit den Telekom-Kundendaten über die WAN-Schnittstelle. Damit man auf die Admin-Konsole des DrayTek draufkommt, läuft über das gleiche Kabel noch ein Outbound NAT auf 192.168.100.0/24.

    Auf dem Router ist der IGMP-Proxy mit korrekten Upstream und Downstreams in beide 192er Subnetze konfiguriert.

    Rechner im OPT1-Netz (192.168.1.0/24) können die rtp-Streams der Telekom empfangen und abspielen (getestet mit VLC, funktioniert grundsätzlich).

    Der Switch im OPT1-Netz hat auch ein WLAN-Modul und ist NICHT IGMP v3-fähig. Entertain funktioniert trotzdem auch über WLAN.

    Rechner iM LAN (192.168.0.0/24) (dort hängt auch der Media-Receiver der Telekom) kriegen kein Bild. Der Telekom-Receiver bricht bei der Initialisierung mit Fehler 14 ab (TFTP-Problem, bekannt, siehe z.B: https://forum.pfsense.org/index.php?topic=130319.msg736499#msg736499).

    Stecke ich probehalber einen Rechner direkt an das LAN-Kabel (also direkt an den LAN-Port der pfSense) funktioniert auch dort alles, wie es soll. D.h. die pfSense Firewall-Regeln sollten grundsätzlich OK sein.

    Demnach müsste es am Switch oder der Kombi aus pfSense und Switch liegen.

    Der Switch ist ein Zyxel GS1910-24, der nur VLAN1 konfiguriert hat. Firmware ist auf dem letzten Stand und VLAN1 hat IGMP-Snooping enabled, IGMP-Snooping ist ebenfalls enabled wie von Zyxel beschrieben.

    Testhalber kann man das IGMP-Snooping am Switch auch komplett abschalten, hilft aber nix.

    An sich sollte es aber gehen.

    Tut es aber nicht.

    Weis jemand Rat?

    P.S: Ich poste gerne mehr Details (alle Konfigs der pfSense, alle Konfigs des Switches, ggf. Wireshark-Mitschnitte). Im Moment verstehe ich es aber einfach nicht.



  • Hi,

    du flutest dein OPT1 und dein WLAN mit Broadcasts, genau deshalb sollte der Switch ja IGMP können.

    Ich denke, dass es ein Problem des Zyxel ist. Du kannst und solltest aber die Konfig und Rules der pfsense hier posten, sonst kann keiner was machen.

    Der Zyxel 1900 soll nur auf IGMP enabled, v3 und flood gestellt werden müssen. Wobei ich das flood für falsch halte, aber es kann ja erstmal zu Testzwecken an sein. Ob der 1910 genau so geht weiß ich nicht, ich habe auch kein Entertain.

    Gruß
    pfadmin