Multi WAN IPv6



  • Hallo!

    Ich nutze ein Multi WAN (Unitymedia & Telekom). Beide Anschlüsse sind mit Dual Stack angebunden. IPv4 läuft sauber, doch bei IPv6 hakt es da ich im LAN Interface nur ein WAN als Tracked Interface angeben kann. Sobald ein WAN down geht, muss ich das Tracked Interface somit erst von Hand auf das andere WAN setzen, was äußerst unpraktisch ist.

    Kann man das eleganter lösen?


  • Moderator

    Eigentlich gar nicht, da weder Unitymedia noch Telekom sauberes v6 bieten sondern beide nur Prefixe die sich ständig ändern, was sie für sinnvollen Einsatz leider disqualifiziert seufz

    Was du aber an der Stelle nutzen kannst - und wehe jetzt kommt jemand und sagt NAT, der bekommt die Prügelstrafe :P - ist NPt. Das ist leider einer der seltenen aber validen Einsatzzwecke für NPt. Im Prinzip also auf dem LAN statische IPv6 vergeben aus dem aus dem Unique Local Unicast Bereich (FD00 - bitte random generieren und erst genau nachlesen! RFC4193) und die auf das LAN legen. Dann per NPt die Prefixe, die auf den WANs ankommen quasi 1:1 auf den Unicast Bereich mappen. Also den Prefix Teil tauschen und den Identifier Teil beibehalten.

    Grüße



  • Ja mit NPt habe ich auch schon gespielt, bin aber gescheitert. Muss ich auf dem LAN dann einen DHCPv6 Server laufen lassen? Bzw. was muss ich am WAN anfordern? DHCPv6, SLAAC?
    Wenn ich bei Unitymedia im LAN nicht mit Tracked Interface arbeite, bekomme ich von ihnen gar keine IPv6 zugewiesen  :-\

    Wenn die Prefixe sich ändern, wie kann ich sie dann mappen? Den Prefix muss ich doch im NPt eintragen oder?

    Danke!


  • Moderator

    Muss ich auf dem LAN dann einen DHCPv6 Server laufen lassen?

    Muss nicht, wäre aber ggf. sinnvoll. Zumindest dass DNS/NTP an Clients gepusht wird, also Assisted.

    Bzw. was muss ich am WAN anfordern? DHCPv6, SLAAC?

    Das was die Provider vorgeben - das weiß ich ja nicht.

    Wenn ich bei Unitymedia im LAN nicht mit Tracked Interface arbeite, bekomme ich von ihnen gar keine IPv6 zugewiesen  :-\

    Dann stimmt deine Einstellung nicht, DHCP6 sollte klappen - mit Einstellungen.

    Ah, das habe ich überlesen, dass beide Prefixe dynamisch sind. Das wird wahrscheinlich dann nicht laufen. Es sei denn der zugewiesene Prefix-Bereich für dich bleibt gleich und nur der Upstream-Prefix ändert sich.

    Gruß