I have a problem with bridged modem connecting to pfsense



  • So My setup goes like this: router > server (esxi 6.5) > pfsense > switch > computers

    So i put My router to bridge mode because of double nat but now only esxi 6.5 gets IP not pfsense and The IP IS My public IP
    So i was thinking IS there any way to Make pfsense get The IP?


  • Rebel Alliance Global Moderator

    Yeah connect pfsense to isp device.  Why would you have pfsense behind our esxi host?

    Is your esxi host running pfsense as VM?  If so connect isp to vswitch interface that pfsense wan is connected too..

    You would not connect your vmkern to your ISP directly.



  • yes my pfsense is running as VM
    and it works if i disable bridge mode on my router and i got it to kinda work with bridge mode i could connect to the routers gui but i didn't get internet access
    oh btw i put the pfsense in esxi because i don't have any other computer to run it and it was really easy to do it too

    my config:
    https://gyazo.com/017926cb138a9e7cad53b5657afa55ff
    https://gyazo.com/cda365650f6570ab753b6465cb8de965
    https://gyazo.com/193adc168ea8390e6dd8386589fc62c6
    https://gyazo.com/68907d2cdbd1810323e71289e8b0f2a9

    and when i tried it with bridge mode enabled on router:
    https://gyazo.com/0c8eab4e491734a4637c3c1b9867b6e0
    https://gyazo.com/7f12505d14b665d54533dc7ce5341b1d
    i could connect to the routers gui but i couldn't access the internet



  • Looks like you got the esxi networking backwards, there's a guide in the wiki how to do it right:
    https://doc.pfsense.org/index.php/PfSense_on_VMware_vSphere_/_ESXi



  • hey AndyC just to be clear it works rn but if i put my moden into bridge mode and change couple of the settings it wont give internet
    and ill take a look at the tutorial


  • Rebel Alliance Global Moderator

    I ran pfsense on VM for years and years..

    Your network is wrong..

    Break your your vmkern to be on different vswitch than port group on your wan.

    It should be like this

    pfsense vnic (wan) – wan vswitch --- esxi wan nic --- modem

    Don't put any other port groups on that.  How many interfaces do you have 5?  Break out your vmkern to its own vswitch vs sharing it.. It can be connect to same lan network if you wan..



  • https://gyazo.com/5b44cc10b86a2787aa00d1c6f045142a
    so should i create vswitch for VM Network, Management Network and one for Network (WAN) and one for Network (LAN)?
    ive got 3 ether cables going to the server: 1 from modem, 1 from switch and 1 for IMM


  • Rebel Alliance Global Moderator

    Yes or you need to use vlan to break them out - you have 3 ports groups on the same vswitch0.. Unless you create tags for these port groups or setup them to 4095 and set the tags before the traffic hits the pfsense you have placed all of those networks on the same layer 2.

    I have moved away from esxi.. Just recently wiped that box.. I have hardware pfsense now and just running the few vms I Need on my synology nas.

    You can do it with port groups on the same vswitch if you set the tags correctly on your physical network.  But its more complex setup.



  • @johnpoz:

    Yes or you need to use vlan to break them out - you have 3 ports groups on the same vswitch0.. Unless you create tags for these port groups or setup them to 4095 and set the tags before the traffic hits the pfsense you have placed all of those networks on the same layer 2.

    I have moved away from esxi.. Just recently wiped that box.. I have hardware pfsense now and just running the few vms I Need on my synology nas.

    You can do it with port groups on the same vswitch if you set the tags correctly on your physical network.  But its more complex setup.

    He is right. Unless you are really good with esxi just make different vswitches.

    1. Leave your vmk on vswitch0 (this is for mgmt)
    2. Make a new vswitch, call it WAN, assign a NIC to it and make a port group called WAN.
    3. Make a new vswitch, call it LAN and assign it a NIC, make new port group called LAN.
    4. Plug your modem into the WAN NIC, plug your inside switch or whatever into the LAN NIC, and your good.

    I had to restart my modem for the WAN interface to pull a public IP, once it does I've never had a problem since (including using ipv6 if your ISP supports this)