VPN IPSEC sin trafico



  • Hola,

    Soy nuevo en este foro, tengo un problema con una VPN S2S con IPSEC, logro conectar ambas redes pero al momento de hacer ping no logro conexión, he buscado informacion pero no logro ver donde puede estar el problema, la otra parte me comenta que puede ser las tablas de ruta, como veo esto en pfsense? rutas estáticas?, tengo otra VPN IPSEC s2s que funciona sin problema.

    la red esta asi.
                                                                (ipsec)
    192.168.5.0/24=====>201.236.X.X    =============    186.67.X.X ==========< 10.43.22.121

    Esto saque del log de IPSEC

    May 7 12:15:58 charon 07[IKE] deleting IKE_SA con2000[47] between 201.236.X.X[201.236.X.X]…186.67.X.X[186.67.X.X]
    May 7 12:15:58 charon 07[IKE] <con2000|47>deleting IKE_SA con2000[47] between 201.236.X.X[201.236.X.X]…186.67.X.X[186.67.X.X]
    May 7 12:43:26 charon 11[IKE] initiating Main Mode IKE_SA con2000[48] to 186.67.X.X
    May 7 12:43:26 charon 11[IKE] <con2000|48>initiating Main Mode IKE_SA con2000[48] to 186.67.X.X
    May 7 12:43:26 charon 11[NET] sending packet: from 201.236.X.X[500] to 186.67.X.X[500] (180 bytes)
    May 7 12:43:26 charon 11[NET] <con2000|48>sending packet: from 201.236.X.X[500] to 186.67.X.X[500] (180 bytes)
    May 7 12:43:26 charon 11[NET] received packet: from 186.67.X.X[500] to 201.236.X.X[500] (108 bytes)
    May 7 12:43:26 charon 11[NET] <con2000|48>received packet: from 186.67.X.X[500] to 201.236.X.X[500] (108 bytes)
    May 7 12:43:26 charon 11[NET] sending packet: from 201.236.X.X[500] to 186.67.X.X[500] (196 bytes)
    May 7 12:43:26 charon 11[NET] <con2000|48>sending packet: from 201.236.X.X[500] to 186.67.X.X[500] (196 bytes)
    May 7 12:43:26 charon 05[NET] received packet: from 186.67.X.X[500] to 201.236.X.X[500] (256 bytes)
    May 7 12:43:26 charon 05[NET] <con2000|48>received packet: from 186.67.X.X[500] to 201.236.X.X[500] (256 bytes)
    May 7 12:43:26 charon 05[NET] sending packet: from 201.236.X.X[500] to 186.67.X.X[500] (108 bytes)
    May 7 12:43:26 charon 05[NET] <con2000|48>sending packet: from 201.236.X.X[500] to 186.67.X.X[500] (108 bytes)
    May 7 12:43:26 charon 13[NET] received packet: from 186.67.X.X[500] to 201.236.X.X[500] (92 bytes)
    May 7 12:43:26 charon 13[NET] <con2000|48>received packet: from 186.67.X.X[500] to 201.236.X.X[500] (92 bytes)
    May 7 12:43:26 charon 13[IKE] IKE_SA con2000[48] established between 201.236.X.X[201.236.X.X]…186.67.X.X[186.67.X.X]
    May 7 12:43:26 charon 13[IKE] <con2000|48>IKE_SA con2000[48] established between 201.236.X.X[201.236.X.X]…186.67.X.X[186.67.X.X]

    Cualquier ayuda se agradece.

    Saludos.</con2000|48></con2000|48></con2000|48></con2000|48></con2000|48></con2000|48></con2000|48></con2000|48></con2000|47>



  • Has hecho debug en los log del firewall? Por si acaso no has dado permiso a nivel de reglas de firewall.



  • Hola, gracias por tu respuesta, Si  le di todos los permisos al firewall.

    El debug a los logs del firewall no sale nada



  • Hola

    Que validaciones has hecho

    Phase 1 funciona
    Phase 1 funciona pero phase 2 no



  • @😄:

    Hola

    Que validaciones has hecho

    Phase 1 funciona
    Phase 1 funciona pero phase 2 no

    Hola, si ambas fases funcionan, solo el trafico no funciona ni siquiera ping



  • Perfecto

    Estonces el problema paracet estar en las reglas y en el enrutamiento interno puedes dar un ejemplo de lo que quieres y mostrar cómo lo tienes en las reglas?



  • @😄:

    Perfecto

    Estonces el problema paracet estar en las reglas y en el enrutamiento interno puedes dar un ejemplo de lo que quieres y mostrar cómo lo tienes en las reglas?

    Asi es estuve viendo el tema con la contraparte y el tema son las rutas internas,
    Asi tengo la ruta estatica.

    Network                 Gateway                   Interface
    10.43.22.121/32 WANGW - 201.236.X.X WAN

    es asi o deberia hacer otro gw?

    Gracias de antemano.



  • cuando usas ipsec

    no debes agregar la ruta statica, debes crear un regla en la interfaz lan y en la interfaz ipsec



  • @😄:

    cuando usas ipsec

    no debes agregar la ruta statica, debes crear un regla en la interfaz lan y en la interfaz ipsec

    ok gracias y como lo hago?
    sorry soy novato en esto.



  • @P4nach0x:

    @😄:

    cuando usas ipsec

    no debes agregar la ruta statica, debes crear un regla en la interfaz lan y en la interfaz ipsec

    ok gracias y como lo hago?
    sorry soy novato en esto.

    Es solo una regla en el firewall o a cada interfaz?



  • Hola

    Puedes colocar el pantallazo de tus reglas para ver cómo están configuradas?



  • el problema era la versión de pfsense, actualice a la ultima versión y conecto.

    Saludos.