"script-security 3" instead of 2?

  • Looking at /var/etc/openvpn/client2.conf, I'm showing the following option apparently automatically added by pfSense (at least in 2.4.3):

    script-security 3

    According to:


    –script-security level

    This directive offers policy-level control over OpenVPN's usage of external programs and scripts. Lower level values are more restrictive, higher values are more permissive. Settings for level:

    0 -- Strictly no calling of external programs.
    1 -- (Default) Only call built-in executables such as ifconfig, ip, route, or netsh.
    2 -- Allow calling of built-in executables and user-defined scripts.
    3 -- Allow passwords to be passed to scripts via environmental variables (potentially unsafe).

    I assume pfSense uses a >1 level because it also has an –up command in there (i.e., a script).  But, why level = 3?  Why not level = 2?  Are there passwords somewhere in environmental variables?  Also, is there somewhere to change that level under something like VPN > OpenVPN > Clients?

  • I still can't find anyplace in pfSense where script-security is set.  So, it does look like it's defaulting to "script-security 3" instead of something like "script-security 2".  It's a bit worrying that no one knows why it's needed that way.

  • LAYER 8 Global Moderator

    What do you mean nobody knows?  Your thread has been here what not even 3 days yet..

    If your connecting to a vpn service that is using username and passwords then yes.  If they defaulted to 2, that is just one thing that users would dick up and wonder why it doesn't work because they don't read and just click shit ;)

    Kind of how there are hidden firewall rules created when you enable dhcpd that are not shown.  Because the typical user would not know what to enable if not there, and if they were shown would end up deleting and then asking why dhcpd is not working.

    Do you always need to know what they use to make the hotdog?

    If you want to make it 2 - go right ahead and edit the source file so its a 2..


    And update to pfsense will put it back to 3.

    While openvpn might put a warning in the connection about it… Is it really an issue on your firewall, where YOU created the connection to this vpn?

Log in to reply