Client with XP cannot connect with OpenVPN



  • Good morning,

    First of all, I want to say my level in the use of pfsense is beginner, if any information is missing apart from the one I am going to post next, tell me in what section it could be obtained, so I can provide it faster.

    The case is as follows:

    I have configured an access to a local network of a company through OpenVPN, in a Netgate router with pFsense. Currently, users can connect from the outside if they use Windows 7 or Windows 10, but when trying to connect from Windows XP does not establish connection.

    In the main office there is the Netgate with the pfsense configured, from another office I can connect from Windows 7 (in this office they are all Windows 7) and in my house, from my personal computer, I can connect using Windows 10.

    In a third office, using Windows XP does not connect to the target network. (in that office actually there are only Windows XP, so I can't try with Windows 7 or 10, until I can go with my laptop)

    This is the conf file of a user in Windows 7:

    dev tun
    persist-tun
    persist-key
    cipher AES-256-CBC
    ncp-ciphers AES-256-GCM: AES-128-GCM
    auth SHA1
    tls-client
    client
    resolv-retry infinite
    remote 46.24.72.105 1194 udp
    verify-x509-name "SIMSLU Certificate" name
    auth-user-pass
    pkcs12 pfSense-udp-1194-UserVPN1.p12
    tls-auth pfSense-udp-1194-UserVPN1-tls.key 1
    remote-cert-tls server
    [/ quote]

    and this is the user conf file in Windows XP 32 bits (in the attached picture)

    When I try to connect from the XP client, this is what appears in the client's log:

    Options error: Unrecognized option or missing parameter (s) in pfSense-udp-1194-UserVPN1-config.ovpn: 5: ncp-ciphers (2.3.18)
    Use –help for more information. [/ Quote]

    I tried to disable the XP Firewall, in case it had something to do, but still giving the same error.

    I guess problem may be on the conf user file, line 5, between "GCM" and "auth" there's one strange simbol (I tried removing it, but still cannot connect, and same error as before)

    If someone could help me, I would appreciate it. (And if you need more information please tell me what section it is, since I have barely used the netgate / pfsense and I do not know where everything is)



  • That's probably because Windows XP is deprecated for years already and now unsupported?
    I wouldn't want to be online with that Windows version anymore. Really, get a more current Windows version for everything, especially being online.



  • I agree with Chris.

    Apart from this, Windows XP does not support GCM encryption. This is only supported by OpenVPN 2.4, but that cannot be installed on XP. Also NCP is not supported by OpenVPN versions lower 2.4.
    So to connect XP clients to the server you must change the encryption algorithm, e.g. to a CBC version. If you intend to do that, also check "Enable NCP" and select your preferred GCM algorithm from the list below. That enables NCP capable clients to connect with GCM encryption, while elder clients can connect with the algorithm you've selected at "Encryption Algorithm".


  • Rebel Alliance Global Moderator

    Going to chime in as well - XP should no longer be viable OS… If you are using it for some legacy something.  It should not have any sort of network access at all..

    Viragomann work around should be work - but better is to move away from such an OLD OS that has no support.



  • Ok, thank to all of you.

    Yeah, I agree about XP should be retired, but it's not my decision.

    I will try viragomann solution and will let you know about as soon as possible.


  • Rebel Alliance Global Moderator

    Make it their decision to update their OS then.. Sorry "MY" vpn doesn't work with XP since it is non support OS and security issue.

    Update your OS to supported version, or sorry will not be able to connect to "MY" vpn ;)



  • ^ exactly how I would handle this.
    Sometimes people need a hard reminder to change necessary stuff. Now you have the option!



  • I was going to change encryptation but, as you can see on picture attached, it seems to be already as viragomann sujested.

    Is this how it should be or I should change anything?

    I would like to do that, so they change XP to, at least, Windows 7 but as far as I know, my boss already told they will be able with XP (we're a technical support company)

    Again, thanks allf of you for your help.

    ![Sin título.jpg](/public/imported_attachments/1/Sin título.jpg)
    ![Sin título.jpg_thumb](/public/imported_attachments/1/Sin título.jpg_thumb)



  • Maybe it helps to remove the ncp-ciphers line from the client config.



  • I will try tomorrow then.

    Thanks!


  • Rebel Alliance Global Moderator

    "my boss already told they will be able with XP"

    Well clearly your boss spoke out his ass without knowing anything..  That your boss would say XP is fine is clearly out of touch with IT from every angle…



  • Hi all,

    After removing whole line now works.

    So, for anyone that may come in the future with the same problem, solutions is remove the following line only in conf file of windows xp clients

    ncp-ciphers AES-256-GCM: AES-128-GCM

    One more time thanks all of you for your help.

    Have a nice day!


  • Rebel Alliance Developer Netgate

    If you use the client export package, you can click the option to export one of the old windows installers with the "-xp" suffix, and you can also check the "legacy client" option in the export package when making inline configurations.

    But the best thing to do is ditch XP.