Acces serveur mail depuis extérieur OK, depuis LAN non OK



  • Bonjour à tous,

    je suis encore neuf sur pfsense et le routing, voici mon problème.

    J'ai déménager mon serveur postfix derrière mon pfsense tout fraîchement installer.

    Voila basiquement a quoi ressemble l'installation.

    BOX(dmz sur if wan) –--> PF ------>Lan sur switch( Postfix - client - etc ...)

    J'ai redirigé correctement les ports de celui-ci et j'arrive bien a recevoir mes mails et en envoyer depuis l'extérieur (test effectuer avec mon téléphone).

    Sauf que depuis l'intérieur du lan impossible d'envoyer/recevoir.

    Côté DNS, le domain est chez ovh et redirige vers l'ip publique, le problème semble ne pas venir de la vu que comme dis plus haut, depuis l'extérieur je peux interagir sans problème.

    Pour des raisons pratique je veux pouvoir continuer à utiliser le domain dans mon client local.

    Mon problème semble ressembler à celui-ci :
    https://forum.pfsense.org/index.php?topic=147141.0

    Mais j'ai beau appliqué la solution, rien n'y fait. Du coup je prends la tête depuis quelque jours et il est temps de me tourner vers d'autre cerveaux.

    Je suis certain de passer à côté d'un truc stupide.

    Merci par avance de votre aide.



  • As-tu au moins vérifié que, depuis le LAN, la résolution du nom de ton serveur de mail pointe bien vers l'IP interne ?
    Comment fonctionne ton DNS interne ? C'est celui de pfsense ?



  • Salut,

    merci de ton retour.

    J'ai du nouveau et … ça marche ...

    le dns resolver est bien pfsense, et la résolution fonctionnait bien.
    pour le dns, j'utilise la fonction host overide pour faire pointer mon domain externe sur l'ip interne.

    Pourquoi cela c'est mis à fonctionner soudainement. Mystère.



  • en effet, mystère  :-X