Squid



  • Hello everyone, I need help. I have installed a Pfsense (Latest version) as a proxy: Squid Explicit Mode port 3128. When I configure the proxy server in my browser, everything is fine!, Except with private ips that have different ports example: 192.168.1.X: 8443
    These private ip are defined in the local Windows host (system32 / drive / etc / Host) for issues of name resolution. What I need is for these ip to be resolved by the browser and passed through the proxy.

    Note: I already excluded the ip from the browser but having a different port to 80/443 I do not succeed.



  • Why not just tell your OS proxy support to bypass local addresses?  No reason you should go through a proxy just to get to a server on your LAN.



  • KOM thanks for your answer. Sure, that's the idea, but if you put me where I should do those configurations I'd appreciate it.



  • but if you put me where I should do those configurations I'd appreciate it.

    That depends on your OS.  For Windows, in the proxy definition dialog there is a 'Bypass for local addresses' checkbox or something similar.