E2guardian Servisini Tek Başına Kullanmak!



  • Merhabalar,

    Ben 1-2 haftadır e2guardian servisini tek başına kullanmayı denedim fakat tecrübe ettimki tek başına malesef stabil çalışmıyor. Tek başına çalıştığı zaman web filtering ve proxy server görevini tam olarak beceremiyor. Örneğin, tek başına çalıştığında " LAN ve Loopback" arabirimlerini seçip filtreleme yapabiliyorsunuz HTTPS ve HTTP olarak. Ama bundan yaklaşık 1 saat bilemediniz 2-3 saat belki bir sonraki gün "8080 Already in use " adlı bir hata veriyor ve e2guardian servisi çalışmıyor. Tabi siz sistemi yeniden başlattığınızda yine çalışmaya devam ediyor fakat belki 1 saat sonra yine aynı hatayı vericek. Öyle zırt pırt sistemi yeniden başlatamayız.

    Bu hatanın sebebi ise LAN ve Loopback arabirimlerini aynı anda dinlediği için ve 8080 portunu iki arabirim aynı anda kullandığından, saçmalıyor servis.

    En iyisi Squid + E2guardian ikilisini birlikte çalıştırmak. Böyle daha stabil çalışıyor. Muhtemelen dediğim gibi E2guardian servisi proxy server görevini tam olarak göremiyor gibi. Her neyse ufak bir bilgilendirme geçeyim dedim.



  • @ucribrahim:

    Merhabalar,

    Ben 1-2 haftadır e2guardian servisini tek başına kullanmayı denedim fakat tecrübe ettimki tek başına malesef stabil çalışmıyor. Tek başına çalıştığı zaman web filtering ve proxy server görevini tam olarak beceremiyor. Örneğin, tek başına çalıştığında " LAN ve Loopback" arabirimlerini seçip filtreleme yapabiliyorsunuz HTTPS ve HTTP olarak. Ama bundan yaklaşık 1 saat bilemediniz 2-3 saat belki bir sonraki gün "8080 Already in use " adlı bir hata veriyor ve e2guardian servisi çalışmıyor. Tabi siz sistemi yeniden başlattığınızda yine çalışmaya devam ediyor fakat belki 1 saat sonra yine aynı hatayı vericek. Öyle zırt pırt sistemi yeniden başlatamayız.

    Bu hatanın sebebi ise LAN ve Loopback arabirimlerini aynı anda dinlediği için ve 8080 portunu iki arabirim aynı anda kullandığından, saçmalıyor servis.

    En iyisi Squid + E2guardian ikilisini birlikte çalıştırmak. Böyle daha stabil çalışıyor. Muhtemelen dediğim gibi E2guardian servisi proxy server görevini tam olarak göremiyor gibi. Her neyse ufak bir bilgilendirme geçeyim dedim.

    Merhabalar,

    Bende şöyle bir sıkıtntı yaşıyorum Cihaz filtreleme filan çalışıyor cihazı kapatıp kullanıcılarıda kapatıp açınca filtreleme çalışmıyor Firewall kurallarıyla alakalı bir durum varmı diye marcello yada yazdım özel bir firewall kuralına gerek yok diyor defaultta gelen kuralı değiştirmeden kullanabileceğimi söyledi ama bende çok stabil bulmadım açıkçası biraz da soğudum bu durumdan :(

    Not: Kurallarda bir değişiklik yapmadan Listening port kısmından LAN ve Loopback'i  tekrar seçip save diyince çalışmaya başlıyor.



  • Şuan bende sıkıntısız bir şekilde çalışıyor, mutlaka yaptığınız yanlış bir yer vardır. Biraz daha beklerseniz, döküman yazıyorum. Baştan sona sonuç odaklı bir döküman yazıyorum aynı zamanda video da hazırlıcam inşallah.

    Ben sizin söylediğinizden çok fazla birşey anlamadım açıkcası, cihazı kapatıp kullanıcılarıda kapatıp açınca filtreleme çalışmıyor şu cümleden birşey anlayamadım?



  • @landforces:

    @ucribrahim:

    Merhabalar,

    Ben 1-2 haftadır e2guardian servisini tek başına kullanmayı denedim fakat tecrübe ettimki tek başına malesef stabil çalışmıyor. Tek başına çalıştığı zaman web filtering ve proxy server görevini tam olarak beceremiyor. Örneğin, tek başına çalıştığında " LAN ve Loopback" arabirimlerini seçip filtreleme yapabiliyorsunuz HTTPS ve HTTP olarak. Ama bundan yaklaşık 1 saat bilemediniz 2-3 saat belki bir sonraki gün "8080 Already in use " adlı bir hata veriyor ve e2guardian servisi çalışmıyor. Tabi siz sistemi yeniden başlattığınızda yine çalışmaya devam ediyor fakat belki 1 saat sonra yine aynı hatayı vericek. Öyle zırt pırt sistemi yeniden başlatamayız.

    Bu hatanın sebebi ise LAN ve Loopback arabirimlerini aynı anda dinlediği için ve 8080 portunu iki arabirim aynı anda kullandığından, saçmalıyor servis.

    En iyisi Squid + E2guardian ikilisini birlikte çalıştırmak. Böyle daha stabil çalışıyor. Muhtemelen dediğim gibi E2guardian servisi proxy server görevini tam olarak göremiyor gibi. Her neyse ufak bir bilgilendirme geçeyim dedim.

    Merhabalar,

    Bende şöyle bir sıkıtntı yaşıyorum Cihaz filtreleme filan çalışıyor cihazı kapatıp kullanıcılarıda kapatıp açınca filtreleme çalışmıyor Firewall kurallarıyla alakalı bir durum varmı diye marcello yada yazdım özel bir firewall kuralına gerek yok diyor defaultta gelen kuralı değiştirmeden kullanabileceğimi söyledi ama bende çok stabil bulmadım açıkçası biraz da soğudum bu durumdan :(

    Not: Kurallarda bir değişiklik yapmadan Listening port kısmından LAN ve Loopback'i  tekrar seçip save diyince çalışmaya başlıyor.

    Baştan beri bu problem vardı sadece e2guardian kurulu halinde vardı
    tek başına pek kimse kullanmadığı için umursamadılar bu sorunu
    squid kurup e2guardianı sonradan kurunca restartta da sorun cıkarmıyor.
    ben bu şekilde bir çok yapıda devreye aldım



  • @ucribrahim:

    Şuan bende sıkıntısız bir şekilde çalışıyor, mutlaka yaptığınız yanlış bir yer vardır. Biraz daha beklerseniz, döküman yazıyorum. Baştan sona sonuç odaklı bir döküman yazıyorum aynı zamanda video da hazırlıcam inşallah.

    Ben sizin söylediğinizden çok fazla birşey anlamadım açıkcası, cihazı kapatıp kullanıcılarıda kapatıp açınca filtreleme çalışmıyor şu cümleden birşey anlayamadım?

    Şöyle anlatayım; Pfsense çalışıor E2Guardian Servisi çalışıyor 1-2 saat sonra test amaçlı Pfsense makinasını ve test ortamındaki 1-2 Pc'yi kapatıyorum tekrar açıyorum (Yani Mesai bitmiş herkes makinasını vs. kapatıyor ya simüle ediyorum :) ) pfsense ve diğer makinalar açıldıktan sonra bakıyorum E2Guardian Start durumunda ama filtreleme yapmıyor. bende E2Guardian Ayarlarında Listening port kısmından LAN ve Loopback'i  portlarını seçili olmasına rağmen tekrar seçip save edince filtreleme çalışıyor.

    LAB ortamım Wmware Workstaion 14 Pro