Squid Guard Error in 1.16.10 Missing Entry in GUI



  • There is a error in the latest snapshot.
    There is no GUI entry for Squid Guard under Services for Squis Guard.

    I reinstalled the package and received following error:

    >>> Upgrading pfSense-pkg-squidGuard... 
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.
    Checking integrity... done (0 conflicting)
    The following 1 package(s) will be affected (of 0 checked):
    
    Installed packages to be REINSTALLED:
    	pfSense-pkg-squidGuard-1.16.10 [pfSense]
    
    Number of packages to be reinstalled: 1
    [1/1] Reinstalling pfSense-pkg-squidGuard-1.16.10...
    [1/1] Extracting pfSense-pkg-squidGuard-1.16.10: .......... done
    Removing squidGuard components...
    Menu items... done.
    Services... done.
    Loading package instructions...
    
    Parse error: syntax error, unexpected '&&' (T_BOOLEAN_AND) in /usr/local/pkg/squidguard.inc on line 657
    pkg-static: DEINSTALL script failed
    Saving updated package information...
    overwrite!
    Loading package configuration... done.
    Configuring package components...
    Loading package instructions...
    
    Parse error: syntax error, unexpected '&&' (T_BOOLEAN_AND) in /usr/local/pkg/squidguard.inc on line 657
    pkg-static: POST-INSTALL script failed
    Message from pfSense-pkg-squidGuard-1.16.10:
    
    Please visit Services - SquidGuard Proxy Filter - Target Categories and set up at least one category there before enabling SquidGuard. See https://forum.pfsense.org/index.php?topic=94312.0 for details.
    >>> Cleaning up cache... done.
    Success
    
    

    Also a Crash Report was generated:

    					Crash report begins.  Anonymous machine information:
    
    amd64
    11.2-PRERELEASE
    FreeBSD 11.2-PRERELEASE #631 71be493a552(devel-11): Mon May 14 17:59:45 CDT 2018     root@buildbot2.netgate.com:/builder/ce/tmp/obj/builder/ce/tmp/FreeBSD-src/sys/pfSense
    
    Crash report details:
    
    PHP Errors:
    [15-May-2018 10:46:28 Europe/Berlin] PHP Parse error:  syntax error, unexpected '&&' (T_BOOLEAN_AND) in /usr/local/pkg/squidguard.inc on line 657
    [15-May-2018 10:46:28 Europe/Berlin] PHP Parse error:  syntax error, unexpected '&&' (T_BOOLEAN_AND) in /usr/local/pkg/squidguard.inc on line 657
    [15-May-2018 10:46:33 Europe/Berlin] PHP Parse error:  syntax error, unexpected '&&' (T_BOOLEAN_AND) in /usr/local/pkg/squidguard.inc on line 657
    
    No FreeBSD crash data found.
    ```![Auswahl_001.png](/public/_imported_attachments_/1/Auswahl_001.png)
    ![Auswahl_001.png_thumb](/public/_imported_attachments_/1/Auswahl_001.png_thumb)

  • Developer Netgate

    Fixed in the next snapshot (1.16.11)