Neustart pfSense und Windows 10



  • Hallo,

    ich habe das Problem, dass nach einem Neustart der pfSense (hier Standardgateway im Netz, DHCP und einziger DNS-Server) die Windows 10-Clients (per LAN-Kabel angeschlossen, keine Windows-Domäne) jeweils das Netz wieder als neu ansehen und wissen wollen, ob es ein vertrauenswürdiges oder ein öffentliches Netzwerk ist.

    Die Frage könnte ich in einem Windows 10-Forum stellen, aber ich kenne diesen Effekt eben bisher nur von pfSense, nicht von anderen Routern. Daher frage ich hier: Was macht pfsense anders, dass es zu diesem Effekt kommt? Und wie beseitige ich ihn?

    Viele Grüße,
    Oliver



  • Hi,ich habe diesen Effekt nicht.
    Gruß
    pfadmin



  • Das Verhalten kenne ich auch nicht. Denke eher an eine Fehlkonfiguration.



  • Hi,

    ich habe das einige mal installiert und kenne das Problem auch nicht.
    Soweit ich weiß macht windows 10 das an der mac Adresse des Gateway fest. Kann es sein das die IP des Gateway doppelt vergeben ist?



  • Vielen Dank für Eure Hilfsbereitschaft! Dann ist es offenbar ein exotisches Problem. Ich kenne es selber auch von keinem anderen Router. Ich kann es aber hier absolut reproduzieren. Neustart pfSense via Webinterface, anschließend Neustart des PCs -> Windows fragt, ob es ein privates Netzwerk ist, und vergibt in der Bezeichnung eine neue Nummer. ("Netzwerk 57")

    Die IP des Gateways ist nur einmal vergeben. Mir fällt noch ein, dass die PCs statische Adressen haben und die pfSense als Gateway und DNS-Server eingetragen ist.

    Ich bin auch der Meinung, dass Windows sich hier an der MAC orientiert. pfSense läuft auf einem qotom q190g4n und ist derzeit Version 2.4.3-RELEASE-p1 (amd64). Ich habe nirgends MAC-Adressen eingetragen, insofern dürften diese nicht wechseln. Aber es scheint, als würde die pfSense den PCs unterschiedliche MACs signalisieren. Ich bin gerade etwas ratlos, wie ich hier bei der Fehlersuche vorgehen könnte…

    Die qotom-Hardware hat fünf Ports, einer für WLAN, an einem hängt ein Switch mit den beiden PCs, an einem hängt ein WLAN-AP.

    Viele Grüße,
    Oliver



  • Notiere dir die MACs der Qotom, starte diese neu und vergleiche ob sie sich geändert haben. Die Hersteller von solchen billig Kisten machen da oft irgendeinen Mist und verwenden die MACs mehrfach, oder lassen sie beim Systemstart zufällig generieren.



  • Oh-oh: Der Fehler liegt wohl in meiner Konfiguration.

    Die LAN-Anschlüsse haben offenbar feste MACs (00:0e:c4:d0:96:__). Jedoch habe ich eine LAN-Schnittstelle angelegt mit einer Bridge0 - LAN-Kopplung mit Port 2 und Port 3. Dafür wird eine MAC 02:b7:81:12:10:00 angezeigt, und diese ändert sich beim Neustart.

    Ich nehme an, dass diese Adresse von der pfSense zufällig gebildet wird.

    Sollte ich hier eine solche einmal gebildete Adresse bei der Schnittstelle fest eintragen, oder wäre es besser, die MAC eines der beiden Hardware-Ports einzutragen?



  • @ollibraun:

    Sollte ich hier eine solche einmal gebildete Adresse bei der Schnittstelle fest eintragen, oder wäre es besser, die MAC eines der beiden Hardware-Ports einzutragen?

    Weder noch, die korrekte Lösung ist keine Bridge zu verwenden sondern alles über einen ordentlichen Switch anzuschließen. Router Ports sind keine Switch Ports und sollten auch nicht so verwendet werden, dazu gibt es mehr als genug Threads hier im Forum.