VPN zur PFsense



  • Hi, wenn ich auf der PFsense VPN nutzen möchte um da administrative Aufgaben zu machen und die vorgeschaltete FritzBox die PFsense als exposed host hat, was muss ich in der FB einstellen, damit ich da bis zur PFsense komme? und auch in das Netz dahinter?



  • Hi,
    Du musst auf der Fritte den oder die entsprechenden Ports freigeben.
    Das Netz dahinter ist dann eine Frage der Einstellungen auf der pfSense.
    Gruss orcape



  • Wenn du den als exposed Host eingetragen hast, sollten die nötigen Ports schon offen sein. Dann musst du auf der Fritzbox nix mehr machen.

    Allerdings das VPN einrichten auf der pfSense und auf dem Host den vpn client.



  • Sorry, ging jetzt erst wieder....
    Was mir aufgefallen ist beim einrichten des openvpn servers und dann später beim import in meinen LinuxPC:
    In der Inportfile wird ja alles schön gesetzt. Aber die Angabe des Gateways stimmt ja nicht. Die Netzwerkstruktur ist so:
    INET------(feste-IP)FritzBox(192.168.178.1)-------------(192.168.178.25)PFSENSE(192.168.1.1/16)--------SWITCH------PC's
    |
    |
    WLAN (Im composer ist das WLAN unter der Fritzbox. Nur nicht wenn ich es speichere...)

    In der openvpnfile wir die IP des WAN-NICs der PFsense genommen. Das ist die 192.168.178.25 und nicht meine öffentliche fest IP. Damit klappt natürlich keine Verbindung. Wie kann ich diese Verbindung denn ändern, sodass ich hier auch keinen hostnamen nehmen kann?

    Ich finde in dem Wiki leider keine Informationen dazu.


  • Moderator

    @simpsonetti said in VPN zur PFsense:

    In der openvpnfile wir die IP des WAN-NICs der PFsense genommen.

    Die wird nur genommen, wenn du das so stehen lässt. Deshalb hat der entsprechende Tab des Client Export Wizard dafür auch mehrere Einstellungen, von Interface Address bis hin zu DynDNS Name oder manueller Vorgabe ist da alles drin, man muss es nur eintragen und speichern.



  • @jegr said in VPN zur PFsense:

    @simpsonetti said in VPN zur PFsense:

    In der openvpnfile wir die IP des WAN-NICs der PFsense genommen.

    Die wird nur genommen, wenn du das so stehen lässt. Deshalb hat der entsprechende Tab des Client Export Wizard dafür auch mehrere Einstellungen, von Interface Address bis hin zu DynDNS Name oder manueller Vorgabe ist da alles drin, man muss es nur eintragen und speichern.

    Hm, kannst du mir mal einen Screener zeigen? Ich finde das bei mir nicht in VPN->openvpn-> Client Export oder im Servers

    Kann ich das im nachhinein ändern?


  • Moderator

    @simpsonetti Das ist lediglich eine Einstellung, die nur in die Client Konfiguration eingebacken wird. Du kannst die Client Konfig auch selbst umschreiben und da statt der privaten IP eine öffentlichen DNS Namen o.ä. reinschreiben. Das bestimmt lediglich, was im "remote" statement dann als Adresse/URL drinsteht.

    Die Option ist auf dem Reiter

    VPN > OpenVPN > Client Export

    gleich die 2. Option: "Host Name Resolution"
    Dort kann im Pulldown eingestellt werden, was als Verbindungsname genutzt werden soll. Default ist Interface IP, dort tauchen aber auch Dinge wie Hostname, automagic oder konfigurierte DynDNS Namen auf.



  • @jegr said in VPN zur PFsense:

    @simpsonetti Das ist lediglich eine Einstellung, die nur in die Client Konfiguration eingebacken wird. Du kannst die Client Konfig auch selbst umschreiben und da statt der privaten IP eine öffentlichen DNS Namen o.ä. reinschreiben. Das bestimmt lediglich, was im "remote" statement dann als Adresse/URL drinsteht.

    Die Option ist auf dem Reiter

    VPN > OpenVPN > Client Export

    gleich die 2. Option: "Host Name Resolution"
    Dort kann im Pulldown eingestellt werden, was als Verbindungsname genutzt werden soll. Default ist Interface IP, dort tauchen aber auch Dinge wie Hostname, automagic oder konfigurierte DynDNS Namen auf.

    Jetzt habe ich es gesehen. Das ging aber erst, nachdem ich mich aus und wieder eingeloggt habe. Im server waren meine Settings auch alle weg. Ich weiß nicht ob das ein Bug war....
    Nun habe ich es aber richtig gesetzt (hoffe ich) Ich werde das mal testen...

    Danke dir @JeGr


  • Moderator

    @simpsonetti Kein Problem, gern :)