No valid signing SSL certificate configured for HTTPS_port



  • I have been running squid cache for a long time. Last upgrad was to squid-3.5.27_3. I am now getting the following error in my logs: No valid signing SSL certificate configured for HTTPS_port [WAN IP]:443

    What does someone need to do to update this certificate?

    Thank you in advance.



  • After reading related articles and trying to uninstall..reinstall the package. There was still no joy in getting the package to run. The problems started on 06/01/18 after an update. I tried to delete the /usr/local/etc/squid dir and that didn't work either.

    What did work, was to recover the system to a date before the update. The packages were reloaded and ta-da the squid cache came back to life. Should of tried the easy button first.

    Looking back on what I read, there was mention of the CA certificate having a problem and needed to be rebuilt. According to my effective dates it was good for several more years. So, I have no clue as to what went south.

    Really gives reason to backup often and certainly before any upgrade.